易语言组合框添加不重复文本到列表框

视频教程截图

511遇见

易语言组合框添加不重复文本到列表框视频交教程源码:

.版本 2

.子程序 _按钮1_被单击
.局部变量 文本, 文本型

文本 = 组合框1.内容

.如果 (列表框查找文本 (列表框1, 文本) = 真)
列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
.否则

.如果结束

.子程序 列表框查找文本, 逻辑型
.参数 列表框, 列表框
.参数 要加入的文本, 文本型
.局部变量 i, 整数型

.计次循环首 (列表框.取项目数 (), i)
.如果真 (要加入的文本 = 列表框.取项目文本 (i - 1))
返回 (假)
.如果真结束
.计次循环尾 ()
返回 (真)

.子程序 _按钮2_被单击
.局部变量 文本, 文本型

文本 = 组合框1.内容

.如果 (列表框加入项目 (列表框1, 文本) = 真)
信息框 (“加入成功”, 0, , )
.否则
信息框 (“该文本【” + 文本 + “】已经存在,不要重复加入”, 16, , )
.如果结束

.子程序 列表框加入项目, 逻辑型
.参数 列表框, 列表框
.参数 要加入的文本, 文本型
.局部变量 i, 整数型

.计次循环首 (列表框.取项目数 (), i)
.如果真 (要加入的文本 = 列表框.取项目文本 (i - 1))
返回 (假)
.如果真结束

.计次循环尾 ()
列表框.加入项目 (要加入的文本, )
返回 (真)

.子程序 _按钮3_被单击

.如果 (列表框1.选择 (组合框1.取项目文本 (组合框1.现行选中项)) = -1)
列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )

.否则

.如果结束

.子程序 _按钮4_被单击
.局部变量 文本, 文本型

文本 = 组合框1.内容

.如果 (SendMessageA (列表框1.取窗口句柄 (), 399, 0, 文本) = -1)
列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )

.否则
信息框 (“该文本【” + 文本 + “】已经存在,不要重复加入”, 16, , )
.如果结束

.子程序 _按钮5_被单击
.局部变量 项目数量
.局部变量 i

项目数量 = 列表框1.取项目数 ()
.判断开始 (项目数量 = 0)
列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
.判断 (项目数量 > 0)
.计次循环首 (项目数量, i)
.如果 (寻找文本 (列表框1.取项目文本 (i - 1), 组合框1.取项目文本 (组合框1.现行选中项), , 假) ≠ -1)
返回 ()

.否则

.如果结束

.计次循环尾 ()
列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )

.默认

.判断结束

教程下载:


发布日期:

所属分类: 易语言 标签: