第11课易语言大漠剑侠情缘多线程木人巷打多怪

>>> 第六课 511遇见易语言大漠找字FindStrFastEx打多怪实例
多线程木人巷打多怪源码:

.版本 2
.支持库 spec
.支持库 iext
 
.子程序 木人巷打怪, , , 7
.参数 数组序号, 整数型
.局部变量 name, 文本型
.局部变量 i, 整数型
.局部变量 文本, 文本型
.局部变量 文本数组, 文本型, , "0"
.局部变量 文本1, 文本型
.局部变量 文本数组1, 文本型, , "0"
.局部变量 文本2, 文本型
.局部变量 文本数组2, 文本型, , "0"
 
延迟 (5000)
超级列表框1.置标题 (数组序号 - 1, 4, “木人巷打怪中...)
name = “鬼谷|墨攻|天盾|尚贤|水经|影宗|山峦|啸穹|枪澜|非乐|磬竹”
i = 1
.判断循环首 (i = 1)
    处理事件 ()
    文本 = FindStrFastE (291, 167, 510, 369, name, “ebb200-000000, 1, 数组序号)
    文本数组 = 分割文本 (文本,|, )
    MoveTo (到整数 (文本数组 [2])30, 到整数 (文本数组 [3])60, 数组序号)
    延迟 (30)
    LeftClick (数组序号)
    延迟 (30)
    文本1 = FindStrFastE (721, 110, 729, 124,0, “e6b532-000000, 1, 数组序号)
    文本数组1 = 分割文本 (文本1,|, )
    .如果 (到整数 (文本数组1 [1])0)
        延迟 (5000)
        文本2 = FindStrFastE (652, 160, 776, 200, “木人巷退出”, “ffffff-000000, 1, 数组序号)
        文本数组2 = 分割文本 (文本2,|, )
        延时 (300)
        MoveTo (到整数 (文本数组2 [2]), 到整数 (文本数组2 [3]), 数组序号)
        延时 (300)
        LeftClick (数组序号)
        延时 (300)
        i = 0
 
    .否则
        i = 1
    .如果结束
 
.判断循环尾 ()


发布日期:

所属分类: 易语言 标签: