第10课易语言大漠剑侠情缘多线程木人巷参加和领奖

木人巷参加和领奖源码:

.版本 2
.支持库 iext
 
.子程序 木人巷, , , 5
.参数 数组序号, 整数型
.局部变量 文本, 文本型
.局部变量 文本数组, 文本型, , "0"
.局部变量 i, 整数型
 
超级列表框1.置标题 (数组序号 - 1, 4, “点击木人巷”)
i = 1
.判断循环首 (i = 1)
    处理事件 ()
    延时 (300)
    文本 = FindStrFastE (151, 291, 390, 395, “木人巷”, “cae6ab-000000, 1, 数组序号)
    延时 (300)
    文本数组 = 分割文本 (文本,|, )
    延时 (300)
    .如果 (到整数 (文本数组 [1])0)
        延时 (300)
        MoveTo (到整数 (文本数组 [2])5, 到整数 (文本数组 [3])5, 数组序号)
        延时 (300)
        LeftClick (数组序号)
        延时 (300)
        i = 0
 
    .否则
        i = 1
    .如果结束
 
.判断循环尾 ()
.版本 2
.支持库 iext
 
.子程序 木人巷参加, , , 6
.参数 数组序号, 整数型
.局部变量 文本, 文本型
.局部变量 文本数组, 文本型, , "0"
.局部变量 i, 整数型
 
超级列表框1.置标题 (数组序号 - 1, 4, “点击参加木人巷”)
i = 1
.判断循环首 (i = 1)
    处理事件 ()
    延时 (300)
    文本 = FindStrFastE (154, 288, 429, 396, “参加”, “cae6ab-000000, 1, 数组序号)
    延时 (300)
    文本数组 = 分割文本 (文本,|, )
    延时 (300)
    .如果 (到整数 (文本数组 [1])0)
        延时 (300)
        MoveTo (到整数 (文本数组 [2])5, 到整数 (文本数组 [3])5, 数组序号)
        延时 (300)
        LeftClick (数组序号)
        延时 (300)
        i = 0
 
    .否则
        i = 1
    .如果结束
 
.判断循环尾 ()
.版本 2
.支持库 iext
 
.子程序 木人巷奖励, , , 8
.参数 数组序号
.局部变量 文本, 文本型
.局部变量 文本数组, 文本型, , "0"
.局部变量 i, 整数型
 
超级列表框1.置标题 (数组序号 - 1, 4, “木人巷领取奖励”)
i = 1
.判断循环首 (i = 1)
    处理事件 ()
    延时 (300)
    文本 = FindStrFastE (154, 288, 429, 396, “奖励”, “cae6ab-000000, 1, 数组序号)
    延时 (300)
    文本数组 = 分割文本 (文本,|, )
    延时 (300)
    .如果 (到整数 (文本数组 [1])0)
        延时 (300)
        MoveTo (到整数 (文本数组 [2])5, 到整数 (文本数组 [3])5, 数组序号)
        延时 (300)
        LeftClick (数组序号)
        延时 (300)
        i = 0
 
    .否则
        i = 1
    .如果结束
 
.判断循环尾 ()


发布日期:

所属分类: 易语言 标签: