易语言模块API视频教程线程进入许可证(EnterCriticalSection)

------------------------------------------------------------
线程_进入许可证(EnterCriticalSection)
------------------------------------------------------------
多个线程操作相同的数据时,一般是需要按顺序访问的,否则会引导数据错乱,无法控制数据,变成随机变量。为解决这个问题,就需要引入互斥变量,让每个线程都按顺序地访问变量。这样就需要使用EnterCriticalSection和LeaveCriticalSection函数。

api EnterCriticalSection

.版本 2

.DLL命令 EnterCriticalSection, , "kernel32", "EnterCriticalSection", , 线程_进入许可证
.参数 lpCriticalSection, 线程许可证, 传址

模块源码

.版本 2

.子程序 线程_进入许可证, , 公开, 进入已经创建的许可证(线程_创建许可证)
.参数 进入许可证, 线程许可证

EnterCriticalSection (进入许可证)


发布日期:

所属分类: 易语言 标签: