易语言辗转相除求最大公约数

源码:

界面放置三个编辑框,两个用来输入,一个显示最大公约数

.版本 2
 
.子程序 _计算图形按钮_被单击
.局部变量 第一个数, 整数型
.局部变量 第二个数, 整数型
 
第一个数 = 取整 (到数值 (编辑框1.内容))
第二个数 = 取整 (到数值 (编辑框2.内容))
结果编辑框.内容 = 到文本 (取得两个整数的最大公约数 (第一个数, 第二个数))
 
.子程序 取得两个整数的最大公约数, 整数型
.参数 数一, 整数型
.参数 数二, 整数型
.局部变量 操作数甲, 整数型
.局部变量 操作数乙, 整数型
.局部变量 中间数, 整数型
 
操作数甲 = 数一  ' 第一个数
操作数乙 = 数二  ' 第二个数
' 逐次用后一个数去除前一个余数,直到余数是0为止
.判断循环首 (操作数乙 ≠ 0)
    ' 得到中间数
    ' 用小的一个数除大的一个数,得一个余数
    中间数 = 操作数甲 % 操作数乙
    ' 操作数一操作数二 换位
    操作数甲 = 操作数乙
    操作数乙 = 中间数
.判断循环尾 ()
' 返回得到的结果:操作数甲
返回 (操作数甲)

发布日期:

所属分类: 易语言 标签: