易语言大漠单线程模块制作后台找字FindStrFastE

大漠接口说明 FindStrFastE

函数简介:
同FindStrE
易语言用不了FindStrFast可以用此接口来代替
函数原型:
string FindStrFastE(x1,y1,x2,y2,string,color_format,sim)
 
参数定义:
x1 整形数:区域的左上X坐标
y1 整形数:区域的左上Y坐标
x2 整形数:区域的右下X坐标
y2 整形数:区域的右下Y坐标
string 字符串:待查找的字符串, 可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 具体可以查看下面的示例.注意,RGB和HSV格式都支持.
sim 双精度浮点数:相似度,取值范围0.1-1.0
返回值:
 
字符串:
返回字符串序号以及X和Y坐标,形式如"id|x|y", 比如"0|100|200",没找到时,id和X以及Y均为-1"-1|-1|-1"
 
示例:
pos = dm.FindStrFastE(0,0,2000,2000,"长安","9f2e3f-000000",1.0)
pos = split(pos,"|")
If int(pos(0)) >= 0 Then
     dm.MoveTo int(pos(1)),int(pos(2))
End If
 
pos = dm.FindStrFastE(0,0,2000,2000,"长安|洛阳","9f2e3f-000000",0.9)
pos = split(pos,"|")
If int(pos(0)) >= 0 Then
     dm.MoveTo int(pos(1)),int(pos(2))
End If
 
// 查找时,对多行文本进行换行,换行分隔符是"|". 语法是在","后增加换行字符串.任意字符串都可以.
pos = dm.FindStrFastE(0,0,2000,2000,"长安|洛阳","9f2e3f-000000,|",0.9)
pos = split(pos,"|")
If int(pos(0)) >= 0 Then
     dm.MoveTo int(pos(1)),int(pos(2))
End If 
 
注: 此函数比FindStrE要快很多,尤其是在字库很大时,或者模糊识别时,效果非常明显。
推荐使用此函数。
 
另外由于此函数是只识别待查找的字符,所以可能会有如下情况出现问题。
 
比如 字库中有"张和三" 一共3个字符数据,然后待识别区域里是"张和三",如果用FindStrE查找
"张三"肯定是找不到的,但是用FindStrFastE却可以找到,因为"和"这个字符没有列入查找计划中
所以,在使用此函数时,也要特别注意这一点。

模块源码 FindStrFastE

.版本 2
 
.子程序 FindStrFastE, 文本型, 公开, 返回值:(返回字符串序号以及X和Y坐标,形式如"id|x|y", 比如"0|100|200",没找到时,id和X以及Y均为-1"-1|-1|-1")
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 string, 文本型, , string 字符串:待查找的字符串,可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
.参数 color_format, 文本型, , color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 注意,RGB和HSV格式都支持.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
 
返回 (obj.文本方法 (“FindStrFastE”, x1, y1, x2, y2, string, color_format, sim))

《剑侠情缘》测试FindStrFastE源码

.版本 2
.支持库 spec
 
.子程序 _按钮10_被单击, , , FindStrFastE
.局部变量 tmp, 文本型
.局部变量 ss, 文本型, , "0"
.局部变量 x
.局部变量 y
 
tmp = FindStrFastE (0, 0, 2000, 2000, “天盾|鬼谷|墨攻|尚贤”, “ebb200-000000”, 0.9)
' “0|728|147”
调试输出 (tmp)
ss = 分割文本 (tmp, “|”, )
' tmp = “-1|-1|-1”
.如果 (到整数 (ss [1])0)
    x = 到整数 (ss [2])
    y = 到整数 (ss [3])
    MoveTo (x, y)
    延时 (500)
    LeftClick ()
 
.否则
    信息框 (“没有找到”, 0, , )
.如果结束

视频教程优酷土豆链接


发布日期:

所属分类: 易语言 标签:  


下一篇:

没有了,已经是最新文章