易语言去除数组重复成员的源码

.版本 2
.支持库 spec
 
' 去除数组重复成员
.计次循环首 (取数组成员数 (数组), 计次1)
    .如果真 (计次1 > 取数组成员数 (数组))
        跳出循环 ()
    .如果真结束
    .计次循环首 (取数组成员数 (数组) - 计次1, )
        计次2 = 计次2 + 1
        .如果真 (数组[计次1] = 数组[计次1 + 计次2])
            删除成员 (数组, 计次1 + 计次2, )
            计次2 = 计次2 - 1
        .如果真结束
        .如果真 (计次1 + 计次2 = 取数组成员数 (数组))
            计次2 = 0
            跳出循环 ()
        .如果真结束
 
    .计次循环尾 ()
.计次循环尾 ()
调试输出 (数组)

发布日期:

所属分类: 易语言 标签: