易语言DLL制作调用及汇编主程序和DLL交换数据子程序指针

DLL交换数据子程序指针源码:

.版本 2
.支持库 spec
 
.子程序 dll7, , 公开, 7-子程序指针
.参数 保存地址, 整数型
.局部变量 A, 子程序指针
 
交换变量数据_地址交地址ASM (取变量地址_ASM (A), 保存地址)
调用子程序 (A, , , 6, 3,1, “我是信息框标题-来自DLL”)

主程序动态调用DLL

首先建一个子程序,让变量A的类型属于子程序指针。

.版本 2
 
.子程序 _按钮7_被单击, , , 7-子程序指针
.局部变量 A, 子程序指针
.局部变量 地址, 整数型
.局部变量 命令地址, 整数型
.局部变量 参数数据地址, 整数型, , "1"
 
A = &子程序1
地址 = 取变量地址_ASM (A)
命令地址 = 取DLL命令地址_ASM (dll路径, “dll7”)
参数数据地址 [1] = 地址
调用命令_ASM (命令地址, 参数数据地址, )
 
.子程序 子程序1
.参数 a
.参数 b
.参数 c, 文本型
.参数 d, 文本型
 
信息框 (a + b + 到整数 (c), 0, d, )

主程序静态调用DLL

.版本 2
 
.子程序 _按钮7_被单击, , , 7-子程序
.局部变量 地址, 整数型
.局部变量 A, 子程序指针
 
A = &子程序1
地址 = 取变量地址ASM (A)
dll7 (地址)
 
.子程序 子程序1
.参数 a
.参数 b
.参数 c, 文本型
.参数 d, 文本型
 
信息框 (a + b + 到整数 (c), 0, d, )

教程下载:


发布日期:

所属分类: 易语言 标签: