易语言CoCreateGuid随机生成GUID源码

CoCreateGuid

.版本 2
 
.DLL命令 CoCreateGuid, , "ole32", "CoCreateGuid"
    .参数 guid, 字节集

生成新的GUID

.版本 2
 
.子程序 生成新的GUID, 文本型
.局部变量 guid, 字节集
.局部变量 a, 整数型
.局部变量 b, 整数型
.局部变量 c, 整数型
.局部变量 d, 整数型
.局部变量 e, 整数型
.局部变量 f, 整数型
.局部变量 s, 文本型
 
guid = 取空白字节集 (16)
CoCreateGuid (guid)
a = 取字节集数据 (取字节集左边 (guid, 4), #整数型, )
b = 取字节集数据 (取字节集中间 (guid, 5, 2), #整数型, )
c = 取字节集数据 (取字节集中间 (guid, 7, 2), #整数型, )
d = 取字节集数据 (取字节集中间 (guid, 9, 2), #整数型, )
e = 取字节集数据 (取字节集中间 (guid, 11, 2), #整数型, )
f = 取字节集数据 (取字节集右边 (guid, 4), #整数型, )
s = “”
s = s + 取十六进制文本 (a) + “-”
s = s + 取十六进制文本 (b) + “-”
s = s + 到小写 (取十六进制文本 (c)) + “-”
s = s + 取十六进制文本 (d) + “-”
s = s + 取十六进制文本 (e)
s = s + 取十六进制文本 (f)
返回 ({” + s + “})

开始运行被调试程序
* “{23679677-F8C5-45fc-3BE-C7C2773FD869}”


发布日期:

所属分类: 易语言 标签: