易语言SetFileTime设置文件创建修改访问时间

用到的API

.版本 2
 
.DLL命令 创建文件_, 整数型, "kernel32.dll", "CreateFileA", , CreateFile
    .参数 打开文件名, 文本型, , lpFileName,要打开的文件的名字
    .参数 访问权限, 整数型, , dwDesiredAccess,访问权限
    .参数 共享方式, 整数型, , dwShareMode,共享方式
    .参数 安全特性, 整数型, , lpSecurityAttributes,安全特性信息
    .参数 创建方式, 整数型, , dwCreationDisposition,创建方式
    .参数 文件属性, 整数型, , dwFlagsAndAttributes,参见相关帮助
    .参数 从文件复制文件属性, 整数型, , hTemplateFile,参见相关帮助
 
.DLL命令 设置文件时间_, 整数型, "kernel32.dll", "SetFileTime", , SetFileTime
    .参数 系统文件句柄, 整数型, , hFile,系统文件句柄
    .参数 创建时间, 文件时间_, , lpCreationTime,文件的创建时间
    .参数 上一次访问时间, 文件时间_, , lpLastAccessTime,文件上一次访问的时间
    .参数 最近一次修改时间, 文件时间_, , lpLastWriteTime,文件最近一次修改的时间
 
.DLL命令 系统时间到文件时间_, 整数型, "kernel32.dll", "SystemTimeToFileTime", , SystemTimeToFileTime
    .参数 系统时间结构, 系统时间_, , lpSystemTime
    .参数 文件时间结构, 文件时间_, , lpFileTime
 
.DLL命令 关闭内核对象_, 整数型, "kernel32.dll", "CloseHandle", , CloseHandle,非零表示成功,零表示失败
    .参数 对象句柄, 整数型, , hObject,欲关闭的一个对象的句柄
 
.DLL命令 地方文件时间到文件时间_, 整数型, "kernel32.dll", "LocalFileTimeToFileTime", , LocalFileTimeToFileTime
    .参数 地方文件时间结构, 文件时间_, , lpLocalFileTime
    .参数 文件时间结构, 文件时间_, , lpFileTime

数据类型文件时间_和系统时间_

.版本 2
 
.数据类型 文件时间_, , FILETIME
    .成员 日期时间低位, 整数型, , , dwLowDateTime
    .成员 日期时间高位, 整数型, , , dwHighDateTime
 
.数据类型 系统时间_, , SYSTEMTIME
    .成员 年, 短整数型, , , wYear
    .成员 月, 短整数型, , , wMonth
    .成员 周, 短整数型, , , wDayOfWeek
    .成员 日, 短整数型, , , wDay
    .成员 小时, 短整数型, , , wHour
    .成员 分, 短整数型, , , wMinute
    .成员 秒, 短整数型, , , wSecond
    .成员 毫秒, 短整数型, , , wMilliseconds

常量值

  1. .版本 2
    
  2.  
  3. .常量 GENERIC_WRITE, "1073741824"
    
  4. .常量 OPEN_EXISTING, "3"
    
  5. .常量 FILE_SHARE_READ, "1"
    
  6. .常量 FILE_SHARE_WRITE, "1"

易语言修改文件时间源码:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮_设置文件时间_被单击
.局部变量 局部_设置时间, 日期时间型
.局部变量 局部_文件句柄, 整数型
.局部变量 局部_地方时间结构, 文件时间_
.局部变量 局部_文件时间结构, 文件时间_
.局部变量 局部_系统时间结构, 系统时间_

局部_设置时间 = 到时间 (编辑框_被设置的时间.内容)
通用对话框_打开文件.标题 = “请您选择要修改日期的文件”
.如果真 (通用对话框_打开文件.打开 () = 真)
局部_系统时间结构.年 = 取年份 (局部_设置时间)
局部_系统时间结构.月 = 取月份 (局部_设置时间)
局部_系统时间结构.日 = 取日 (局部_设置时间)
局部_系统时间结构.周 = 取星期几 (局部_设置时间) - 1
局部_系统时间结构.小时 = 取小时 (局部_设置时间)
局部_系统时间结构.分 = 取分钟 (局部_设置时间)
局部_系统时间结构.秒 = 取秒 (局部_设置时间)
局部_系统时间结构.毫秒 = 0
系统时间到文件时间_ (局部_系统时间结构, 局部_文件时间结构)
地方文件时间到文件时间_ (局部_文件时间结构, 局部_地方时间结构)
局部_文件句柄 = 创建文件_ (通用对话框_打开文件.文件名, #GENERIC_WRITE, 位或 (#FILE_SHARE_READ, #FILE_SHARE_WRITE), 0, #OPEN_EXISTING, 0, 0)
设置文件时间_ (局部_文件句柄, 局部_地方时间结构, 局部_地方时间结构, 局部_地方时间结构)
关闭内核对象_ (局部_文件句柄)
信息框 (“修改完成”, 0, )
.如果真结束


发布日期:

所属分类: 易语言 标签: