易语言PlaySoundA播放wav声音文件

播放声音文件 PlaySoundA

.版本 2
 
.DLL命令 播放声音文件_, 整数型, "winmm.dll", "PlaySoundA", , 播放声音文件
    .参数 声音文件名, 文本型, , lpszName
    .参数 模块句柄, 整数型, , hModule
    .参数 标志, 整数型, , dwFlags

易语言播放声音文件源码

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
' PlaySoundA的作用是播放一个声音文件
 
.子程序 _按钮_打开路径_被单击
 
通用对话框_打开文件.默认文件后缀 = “*.wav”
通用对话框_打开文件.过滤器 = “*.wav|*.wav”
.如果真 (通用对话框_打开文件.打开 () = 真)
    编辑框_文件路径.内容 = 通用对话框_打开文件.文件名
.如果真结束
 
 
.子程序 _按钮_播放声音文件_被单击
 
.判断开始 (编辑框_文件路径.内容 ≠ “”)
    播放声音文件_ (编辑框_文件路径.内容, 1, 0)
.默认
    编辑框_文件路径.内容 = “请打开一个WAV文件”
.判断结束

发布日期:

所属分类: 易语言 标签: