易语言读写access数据库

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击
.局部变量 查询句柄, 整数型
 
.如果真 (取反 (外部数据库1.打开MDB数据库 (取运行目录 () + “\db.mdb, , , ,)))
    信息框 (“数据库打开失败.”, 0, , )
    返回 ()
.如果真结束
' ----------------------------------------判断是否连接到数据库.
 
查询句柄 = 外部数据库1.查询 (“select * from 表名”)
' 查询句柄,用于读数据,可以添加条件筛选.比如:
' 查询句柄 = 外部数据库1.查询 (“select * from 表名 where name =” + 编辑框2.内容)
 
' -----------------------------------------开始读取数据
.判断循环首 (取反 (外部数据库1.尾记录后 (查询句柄)))
    列表框1.加入项目 (外部数据库1.读 (查询句柄, 2), )
    ' 这里的2表示字段位置,也可以直接写名字,比如字段2为name
    ' 外部数据库1.读 (查询句柄, “name”)
 
    外部数据库1.到后一记录 (查询句柄)
.判断循环尾 ()
外部数据库1.关闭记录集 (查询句柄)
' 记录集使用完毕后及时关闭.
 
' ----------------------------------------- 写数据很简单,直接执行sql语句.
.判断开始 (外部数据库1.执行 (“insert into 表名 (对应表内字段名称1,对应表内字段名称2) values ('内容','内容'), ))
    信息框 (“成功”, 0, , )
.默认
    信息框 (“失败”, 0, , )
.判断结束
' 内容这里注意前后的单引号必须有.示例:
' 外部数据库1.执行 (“insert into 表名 (ID,name) values ('” + 编辑框1.内容 + “','” + 编辑框2.内容 + “'), )
 
' ------------------------------------------修改命令 update
.判断开始 (外部数据库1.执行 (“update 表名 Set ID='” + 编辑框1.内容 + “',name='” + 编辑框2.内容, ))
    信息框 (“成功”, 0, , )
.默认
    信息框 (“失败”, 0, , )
.判断结束
 
' ---------------------------------------删除命令 delete
.判断开始 (外部数据库1.执行 (“delete from 表名 where 条件”, ))
    ' 示例:
    ' 外部数据库1.执行 (“delete from 表名 where name=” + 编辑框2.内容, )
    信息框 (“成功”, 0, , )
.默认
    信息框 (“失败”, 0, , )
.判断结束
 
 
.子程序 __启动窗口_将被销毁
 
外部数据库1.关闭 ()

几个简单的基本的sql语句

 
选择:select * from table1 where Id=1(Id=1为条件语句,根据自己情况自定义)
插入:insert into table1(field1,field2) values(value1,value2)
删除:delete from table1 where 范围
更新:update table1 set field1=value1 where 范围
查找:select * from table1 where field1 like ’%value1%
sql = “insert into 成绩表(姓名,学号,成绩)values('” + 编辑框1.内容 + “','” + 编辑框2.内容 + “','” + 编辑框3.内容 + “')”
 
.如果 (_启动窗口.数据库连接1.执行SQL (sql, ) = 真)
 
    信息框 (“插入成功”, 0, , )
 
.否则
 
    信息框 (“插入失败”, 0, , )
 
注:sql是文本型变量,sql语句的格式为
 
insert into 表名(123)values('” + 数据1 + “','” + 数据2 + “','” + 数据3 + “')”
 
姓名、学号、成绩均为字段名。

发布日期:

所属分类: 易语言 标签: