第15课易语言大漠一键登录判断游戏登录成功

源码:

.版本 2
.支持库 spec
 
.子程序 登录成功, , , 判断游戏是否登录成功
.局部变量 i, 整数型
.局部变量 c_array, 文本型, , "0"
.局部变量 color, 文本型
.局部变量 word, 文本型
.局部变量 w_array, 文本型, , "0"
.局部变量 wordd, 文本型
.局部变量 ww_array, 文本型, , "0"
.局部变量 文本4, 文本型
.局部变量 文本数组4, 文本型, , "0"
 
i = 0
' 判断是否登录成功进入了游戏界面、
.判断循环首 (i = 0)
    color = dm.FindStrFastE (0, 0, 795, 548, “等级”, “ffffff-000000”, 1)
    c_array = 分割文本 (color, “|”, )
    .如果 (到整数 (c_array [1]) ≥ 0)
        i = 1
 
    .否则
 
    .如果结束
    处理事件 ()
.判断循环尾 ()
 
.计次循环首 (3, )
    延迟 (time)
    处理事件 ()
    word = dm.FindStrFastE (155, 301, 569, 374, “提醒”, “cae6ab-000000”, 1)
    延迟 (time)
    w_array = 分割文本 (word, “|”, )
    延迟 (time)
    .如果真 (到整数 (w_array [1]) ≥ 0)
        dm.MoveTo (到整数 (w_array [2]), 到整数 (w_array [3]))
        延迟 (time)
        dm.LeftClick ()
        延迟 (time)
        跳出循环 ()
    .如果真结束
 
.计次循环尾 ()
' 包十八新手任务
 
.计次循环首 (3, )
    延迟 (time)
    处理事件 ()
    wordd = dm.FindStrFastE (198, 190, 294, 227, “包十”, “cae6ab-000000, 1)
    延迟 (time)
    ww_array = 分割文本 (wordd,|, )
    延迟 (time)
    .如果真 (到整数 (ww_array [1])0)
        dm.MoveTo (到整数 (ww_array [2]), 到整数 (ww_array [3]))
        延迟 (time)
        dm.LeftClick ()
        延迟 (time)
        跳出循环 ()
 
    .如果真结束
 
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: