易语言加入不重复文本数组源码

.版本 2

.子程序加入不重复文本数组, , 公开, 只添加不重复的成员
.参数 数组名, 文本型, 数组
.参数 文本, 文本型
.参数 是否排序, 逻辑型, 可空, 为空不排序
.局部变量 I, 整数型

.如果 (是否为空 (是否排序) = 假 或 是否排序 = 真)
.如果 (取数组成员数 (数组名) = 0 或 数组名 [取数组成员数 (数组名)] < 文本)
加入成员 (数组名, 文本)
返回 ()
.否则
.计次循环首 (取数组成员数 (数组名), I)
.如果 (数组名 [I] = 文本)
返回 ()
.否则
.如果真 (数组名 [I] > 文本)
插入成员 (数组名, I, 文本)
返回 ()
.如果真结束

.如果结束

.计次循环尾 ()
.如果结束

.否则
.计次循环首 (取数组成员数 (数组名), I)
.如果真 (数组名 [I] = 文本)
返回 ()
.如果真结束

.计次循环尾 ()
加入成员 (数组名, 文本)


发布日期:

所属分类: 易语言 标签: