易语言模块API教程进程名取ID

用到的API

用到的API
1、CreateToolhelp32Snapshot(创建进程快照)
2、Process32First(取第一个进程)
3、Process32Next(取下一个进程)
4、CloseHandle(关闭一个内核对象)

进程_名取ID

.版本 2

.子程序 进程_名取ID, 整数型, 公开, 通过进程影像名称来获取进程ID,失败返回 0
.参数 进程名, 文本型, , 要取的进程的名称
.参数 是否区分大小写, 逻辑型, 可空, 为空默认不区分大小写,真为区分大小写
.局部变量 进程快照, 整数型
.局部变量 局_进程信息, 进程信息列表
.局部变量 进程句柄, 整数型

' 参数选2 表示:在快照中包含系统中所有的进程。
进程快照 = CreateToolhelp32Snapshot (2, 0)
.如果真 (进程快照 = 0)
返回 (0)
.如果真结束
' 初始化进程信息列表
局_进程信息.dwSize = 512
' 获取第一个进程句柄
进程句柄 = Process32First (进程快照, 局_进程信息)
.判断开始 (是否区分大小写)
.判断循环首 (进程句柄 ≠ 0)
.如果真 (到文本 (局_进程信息.进程名称) = 进程名)
CloseHandle (进程快照)
返回 (局_进程信息.进程ID)
.如果真结束
进程句柄 = Process32Next (进程快照, 局_进程信息)
.判断循环尾 ()
.默认
.判断循环首 (进程句柄 ≠ 0)
.如果真 (到小写 (到文本 (局_进程信息.进程名称)) = 到小写 (进程名))
CloseHandle (进程快照)
返回 (局_进程信息.进程ID)
.如果真结束
进程句柄 = Process32Next (进程快照, 局_进程信息)
.判断循环尾 ()
.判断结束
CloseHandle (进程快照)
返回 (0)


发布日期:

所属分类: 易语言 标签: