易语言模块API教程进程名取句柄

文章目录[隐藏]

进程名取句柄 源码

.版本 2

.子程序 进程_名取句柄, 整数型, 公开, 通过进程名称取得相应的窗口的句柄,成功返回窗口句柄,失败返回0,返回-1表示为找到进程PID
.参数 进程名, 文本型, , 要获取的窗口句柄的进程名称
.局部变量 pid, 整数型, , , 进程ID
.局部变量 hwnd, 整数型, , , 窗口句柄

pid = 进程_名取ID (进程名, )
.如果真 (pid ≠ 0)
返回 (进程_ID取窗口句柄 (pid, , , ))

.如果真结束
返回 (-1)


发布日期:

所属分类: 易语言 标签: