易语言IsWow64Process判断是否Wow64进程

IsWow64Process

.版本 2
 
.DLL命令 是否Wow64进程_, 整数型, "kernel32.dll", "IsWow64Process", , 不支持Win9x/ME
    .参数 进程句柄, 整数型, , hProcess
    .参数 Wow64进程返回值, 整数型, 传址, 如果为Wow64进程,返回非0,否则返回0

GetCurrentProcess

.版本 2
 
.DLL命令 取当前进程伪句柄_, 整数型, "kernel32.dll", "GetCurrentProcess"

GetNativeSystemInfo

.版本 2
 
.DLL命令 取本地系统信息_, , "kernel32.dll", "GetNativeSystemInfo", , 不支持Win9x/ME
    .参数 系统信息, 系统信息_, , lpSystemInfo

易语言前台调用源码

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮_测试_被单击
.局部变量 局部_变量, 整数型
.局部变量 局部_系统信息, 系统信息_
 
是否Wow64进程_ (取当前进程伪句柄_ (), 局部_变量)
.判断开始 (局部_变量 = 0)
    编辑框_运行结果.内容 = “This application is not running on an x86 emulator for a 64-bit computer!”
.默认
    取本地系统信息_ (局部_系统信息)
    编辑框_运行结果.内容 = “Number of processors on your 64-bit system: ” + 到文本 (局部_系统信息.处理器数字)
.判断结束

数据类型系统信息

.版本 2
 
.数据类型 系统信息_
    .成员 OemOEM字符集标志, 整数型, , , dwOemID
    .成员 页大小, 整数型, , , dwPageSize
    .成员 最小应用程序地址, 整数型, , , lpMinimumApplicationAddress
    .成员 最大应用程序地址, 整数型, , , lpMaximumApplicationAddress
    .成员 当前处理器掩码, 整数型, , , dwActiveProcessorMask
    .成员 处理器数字, 整数型, , , dwNumberOrfProcessors
    .成员 处理器类型, 整数型, , , dwProcessorType
    .成员 分配间隔尺寸, 整数型, , , dwAllocationGranularity
    .成员 保留参数, 整数型, , , dwReserved

发布日期:

所属分类: 易语言 标签: