易语言PrinterProperties启动打印机设置属性对话框

打开打印机 OpenPrinterA

.版本 2
 
.DLL命令 打开打印机_, 整数型, "winspool.drv", "OpenPrinterA"
    .参数 打印机名称, 文本型, , pPrinterName,要打开的打印机的名字
    .参数 打印机句柄, 整数型, 传址, phPrinter,用于装载打印机的句柄
    .参数 打印机信息, 打印默认_, 传址, pDefault,PRINTER_DEFAULTS,这个结构保存要载入的打印机信息

启动打印机属性对话框 PrinterProperties

.版本 2
 
.DLL命令 启动打印机属性对话框_, 整数型, "winspool.drv", "PrinterProperties"
    .参数 父窗口句柄, 整数型, , hwnd,对话框的父窗口
    .参数 打印机句柄, 整数型, , hPrinter,一个已打开的打印机的句柄

数据类型PRINTER_DEFAULTS

.版本 2
 
.数据类型 打印默认_, , PRINTER_DEFAULTS
    .成员 数据类型, 文本型, , , pDatatype
    .成员 设备模式, 整数型, , , pDevMode
    .成员 权限标志, 整数型, , , DesiredAccess

易语言启动打印机属性对话框

  1. .版本 2
  2.  
  3. .程序集 窗口程序集_启动窗口
  4.  
  5. .子程序 __启动窗口_创建完毕
  6.  
  7. ' 启动打印机属性对话框,以便对打印机进行配置。
  8. ' Long,非零表示成功,零表示失败。会设置GetLastError。
  9. ' 如打印机打开的时候没有使用足够的访问权限,对话框的有些功能也许会禁止使用。
  10.  
  11. .子程序 _按钮_启动打印机属性对话框_被单击
  12. .局部变量 局部_打印机句柄, 整数型
  13. .局部变量 局部_打印默认, 打印默认_
  14.  
  15. 局部_打印默认.设备模式 = 0
  16. 局部_打印默认.权限标志 = 8
  17. 打开打印机_ (编辑框_打印机名称.内容, 局部_打印机句柄, 局部_打印默认)
  18. .判断开始 (局部_打印机句柄 = 0)
  19.     编辑框_运行结果.内容 = “打开属性对话框失败”
  20. .默认
  21.     启动打印机属性对话框_ (_启动窗口.取窗口句柄 (), 局部_打印机句柄)
  22.     编辑框_运行结果.内容 = “打开属性对话框成功”
  23. .判断结束

发布日期:

所属分类: 易语言 标签: