易语言模块API视频教程线程销毁(TerminateThread)

API

1、GetExitThread

说明

获取一个已中止线程的退出代码

返回值

Long,非零表示成功,零表示失败。会设置GetLastError

参数表

参数 类型及说明

hThread Long,想获取退出代码的一个线程的句柄

lpExitCode Long,用于装载线程退出代码的一个长整数变量。如线程尚未中断,则设为常数STILL_ACTIVE
-----------------------------

.版本 2

.DLL命令 GetExitCodeThread, 整数型, "kernel32", "GetExitCodeThread", 公开, _取中止线程退出代码
.参数 线程句柄, 整数型
.参数 退出代码, 整数型, 传址

-----------------------------
2、TerminateThread

在线程外终止一个线程,用于强制终止线程。

参数

HANDLE hThread:被终止的线程的句柄,为CWinThread指针。

DWORD dwExitCode:退出码。

返回值

函数执行成功则返回非零值,执行失败返回0。调用getlasterror获得返回的值。
3、封装说明

TerminateThread(hThread,dwExitCode)

这个API中,参数 dwExitCode, 是一个线程退出代码,这个代码是你可以自动定义的的一整数,你喜欢设定什么整数都可以,如,123,456,0,789,任何数
这个参数的作用,就是你在调用这个API终止一个外部线程时,给这个被终止的外部线程做一个退出标志,
然后当你调用另一个API GetExitCodeThread(hThread,dwExitCode)时,就可以获取到那个被你终止的线程,当时设置的dwExitCode退出标志代码。

封装源码

.版本 2

.子程序 线程_销毁, 逻辑型, 公开, 强制终止正在运行的线程,成功返回真,失败返回假
.参数 线程句柄, 整数型, , 创建线程返回的句柄
.局部变量 lpExitCode, 整数型, , , 装载线程退出代码的一个长整数变量

GetExitCodeThread (线程句柄, lpExitCode)
返回 (TerminateThread (线程句柄, lpExitCode))


发布日期:

所属分类: 易语言 标签: