易语言教程逻辑比较-取反(按钮播放暂停)

一、官方源码

近似等于
调用格式: 〈逻辑型〉 近似等于 (文本型 被比较文本,文本型 比较文本) - 系统核心支持库->逻辑比较
英文名称:like
当比较文本在被比较文本的首部被包容时返回真,否则返回假,运算符号为“?=”或“≈”。本命令为初级命令。
参数<1>的名称为“被比较文本”,类型为“文本型(text)”。
参数<2>的名称为“比较文本”,类型为“文本型(text)”。

操作系统需求: Windows、Linux
取反
调用格式: 〈逻辑型〉 取反 (逻辑型 被反转的逻辑值) - 系统核心支持库->逻辑比较
英文名称:not
如果参数值为真则返回假,如果参数值为假则返回真。本命令为初级命令。
参数<1>的名称为“被反转的逻辑值”,类型为“逻辑型(bool)”。

操作系统需求: Windows、Linux、Unix

教程源码:

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 集_开关, 逻辑型

.子程序 _按钮1_被单击
.局部变量 a, 文本型
.局部变量 b, 文本型

a = 编辑框1.内容 ' 被比较文本
b = 编辑框2.内容 ' 比较文本
' 当比较文本在被比较文本的首部被包容时返回真,否则返回假,运算符号为“?=”或“≈”。本命令为初级命令。
信息框 (a ≈ b, 0, “近似等于返回的逻辑值”, )

.子程序 _按钮2_被单击

播放音乐4 ()

.子程序 播放音乐1

.如果 (按钮2.标题 = “播放”)
播放MP3 (-1, 取运行目录 () + “\白月光.mp3”)
按钮2.标题 = “暂停”
.否则
暂停播放MP3 ()
按钮2.标题 = “播放”
.如果结束

.子程序 播放音乐2
.局部变量 开关, 逻辑型, 静态

' 调试输出 (开关)
开关 = 取反 (开关)
' 调试输出 (开关)
.如果 (开关 = 真)
播放MP3 (-1, 取运行目录 () + “\白月光.mp3”)
按钮2.标题 = “暂停”
.否则
暂停播放MP3 ()
按钮2.标题 = “播放”
.如果结束

.子程序 播放音乐3

' 调试输出 (开关)
集_开关 = 取反 (集_开关)
' 调试输出 (开关)
.如果 (集_开关)
播放MP3 (-1, 取运行目录 () + “\白月光.mp3”)
按钮2.标题 = “暂停”
.否则
暂停播放MP3 ()
按钮2.标题 = “播放”
.如果结束

.子程序 播放音乐4

集_开关 = 取反 (集_开关)
按钮2.标题 = 选择 (集_开关, “暂停”, “播放”)
.判断开始 (集_开关)
播放MP3 (-1, 取运行目录 () + “\白月光.mp3”)
.默认
暂停播放MP3 ()
.判断结束


发布日期:

所属分类: 易语言 标签: