易语言防止组合框重复添加项目的三种方法

视频教程截图

511遇见

易语言防止组合框重复添加项目的三种方法源码:

.版本 2
 
.子程序 _按钮2_被单击
 
.如果 (组合框1.选择 (编辑框1.内容) = -1)
    组合框1.加入项目 (编辑框1.内容, )
    信息框 (“添加成功”, 0, , )
.否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加!”, 16, , )
.如果结束
 
.子程序 _按钮3_被单击
 
' 344或322
.如果 (SendMessageA (组合框1.取窗口句柄 (), 344, 0, 编辑框1.内容) = -1)
    组合框1.加入项目 (编辑框1.内容, )
    信息框 (“添加成功”, 0, , )
.否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加!”, 16, , )
.如果结束
 
 
.子程序 _按钮4_被单击
.局部变量 i, 整数型
.局部变量 重复, 逻辑型
 
.计次循环首 (组合框1.取项目数 (), i)
    .如果真 (组合框1.取项目文本 (i - 1) = 编辑框1.内容)
        重复 = 真
        跳出循环 ()
    .如果真结束
    重复 = 假
.计次循环尾 ()
.如果 (重复 = 假)
    组合框1.加入项目 (编辑框1.内容, )
    信息框 (“添加成功”, 0, , )
 
.否则
    信息框 (“已经存在【” + 编辑框1.内容 + “】请不要重复添加!”, 16, , )

教程下载:


发布日期:

所属分类: 易语言 标签: