乐玩插件找字扩展FindStrEx和快速找字扩展FindStrFastEx

FindStrEx和快速找字扩展FindStrFastEx模块源码:

.版本 2

.子程序 FindStrFast, 整数型, 公开, 找到返回1,没找到返回0
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 string, 文本型
.参数 color_format, 文本型
.参数 sim, 小数型
.参数 isbackcolor

返回 (obj.数值方法 (“FindStrFast”, x1, y1, x2, y2, string, color_format, sim, isbackcolor))

.子程序 FindStrEx, 文本型, 公开, 找到返回1,没找到返回0
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 string, 文本型
.参数 color_format, 文本型
.参数 sim, 小数型
.参数 isbackcolor

返回 (obj.文本方法 (“FindStrEx”, x1, y1, x2, y2, string, color_format, sim, isbackcolor))

.子程序 FindStrFastEx, 文本型, 公开, 找到返回1,没找到返回0
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 string, 文本型
.参数 color_format, 文本型
.参数 sim, 小数型
.参数 isbackcolor

返回 (obj.文本方法 (“FindStrFastEx”, x1, y1, x2, y2, string, color_format, sim, isbackcolor))

FindStrEx和快速找字扩展FindStrFastEx调用测试源码:

.版本 2
 
.子程序 _按钮21_被单击
 
.计次循环首 (10, )
    木人巷 ()
.计次循环尾 ()
 
.子程序 木人巷
.局部变量 ret, 文本型
.局部变量 ss, 文本型, , "0"
.局部变量 sss, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 id, 整数型
.局部变量 x
.局部变量 y
.局部变量 name, 文本型
 
' 切换字库
l.UseDict (2)
name = “鬼谷|墨攻|天盾|尚贤|水经|影宗|山峦|啸穹|枪澜|非乐|磬竹”
ret = l.FindStrFastEx (0, 0, 2000, 2000, name, “ebb200-000000”, 1, 0)
.如果真 (取文本长度 (ret) > 0)
    ss = 分割文本 (ret, “|”, )
    .计次循环首 (取数组成员数 (ss), i)
        sss = 分割文本 (ss [i], “,”, )
        id = 到整数 (sss [1])
        x = 到整数 (sss [2])
        y = 到整数 (sss [3])
        延时 (100)
        l.MoveTo (x, y)
        延时 (100)
        l.LeftDoubleClick ()
        延时 (100)
    .计次循环尾 ()

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: