乐玩插件多线程后台绑定多窗口-方法1

乐玩多线程流程

---1、必须获取所有的游戏窗口句柄(API)
---2、创建相应的乐玩对象
---3、分别后台绑定窗口
---4、启动线程(两种命令)

需要把之前的模块做一点点改动,原来我们把创建乐玩对象,放在了初始化里,这里我们要单独。

----5、开几个游戏,就把数组声明几个

乐玩多线程游戏调用源码:

.版本 2
.支持库 spec
 
.子程序 多线程绑定
.局部变量 进程ID数组, 整数型, , "0"
.局部变量 m, 整数型
 
' 1、获取游戏窗口句柄
.判断开始 (进程_取ID数组 (“gamefree.exe”, 进程ID数组, ) = 0)
    信息框 (“请先开启游戏!”, 0, , )
.默认
 
.判断结束
游戏窗口数量 = 取数组成员数 (进程ID数组)
调试输出 (游戏窗口数量)
重定义数组 (乐玩, 假, 游戏窗口数量)
重定义数组 (hwnd, 假, 游戏窗口数量)
重定义数组 (thwnd, 假, 游戏窗口数量)
.计次循环首 (游戏窗口数量, m)
    ' 有几个游戏就得创建就几个乐玩对象
    乐玩 [m].创建 ()
    ' 设置全局路径
    ' 设置字库
    ' 屏蔽弹窗错误
    ' 获取句柄
    hwnd [m] = 进程_ID取窗口句柄 (进程ID数组 [m], , , )
    ' 绑定游戏
    .判断开始 (乐玩 [m].BindWindow (hwnd [m], 4, 1, 1, 0, 0) = 1)
        ' 降低CPU
        乐玩 [m].DownCpu (60)
        ' 启动线程
        ' 启动线程 (&主线程, m, thwnd [m])
        thwnd [m] = 线程_启动 (&主线程, m, )
 
    .默认
 
    .判断结束
 
.计次循环尾 ()
 
.子程序 主线程
.参数 d
 
' 这里就是游戏辅助的环节
跑路 (d)
对话 (d)
打怪 (d)
乐玩 [d].UnBindWindow ()
 
.子程序 跑路
.参数 数组序号
 
.计次循环首 (10, )
    乐玩 [数组序号].KeyPress (114, 1)
    超级延时 (1000, )
.计次循环尾 ()
 
.子程序 对话
.参数 数组序号
 
.计次循环首 (10, )
    乐玩 [数组序号].KeyPress (115, 1)
    超级延时 (1000, )
.计次循环尾 ()
 
.子程序 打怪
.参数 数组序号
 
.计次循环首 (10, )
    乐玩 [数组序号].KeyPress (116, 1)
    超级延时 (1000, )
.计次循环尾 ()
 
.子程序 _按钮2_被单击
.局部变量 i, 整数型
 
.计次循环首 (游戏窗口数量, i)
    线程_销毁 (thwnd [i])
.计次循环尾 ()
按钮1.禁止 = 假

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: