易语言模块API视频教程窗口句柄取线程ID(GetWindowThreadProcessId)

api GetWindowThreadProcessId

.版本 2

.DLL命令 GetWindowThreadProcessId, 整数型, "user32", "GetWindowThreadProcessId", 公开, 窗口_句柄取线程ID 获取与指定窗口关联在一起的一个进程和线程标识符 找出某个窗口的创建者(线程或进程),返回创建者的标志符。
.参数 hwnd, 整数型, , 指定窗口句柄;被查找窗口的句柄
.参数 lpdwProcessId, 整数型, 传址, 指定一个变量,用于装载拥有那个窗口的一个进程的标识符

窗口句柄取线程ID 源码

.版本 2

.子程序 窗口_句柄取线程ID, 整数型, 公开, 成功返回指定窗口的线程ID
.参数 窗口句柄, 整数型, , 窗口句柄
.局部变量 进程ID, 整数型, , , 用于装载拥有那个窗口的一个进程的标识符

返回 (GetWindowThreadProcessId (窗口句柄, 进程ID))


发布日期:

所属分类: 易语言 标签: