易语言MulDiv乘除运算

int MulDiv(
                int nNumber,      //32位数值,作为被乘数,
                int nNumerator,   //32位数值,作为乘数,
                int nDenominator, //32位数值,作为被除数
                                  //(分母),nNumber,nNumberator的乘积
                                  //作为除数(分子)
              );

如果返回成功,则结果位乘法和除法的结果,如果溢出或分母(nDenominator)为0,则返回-1。

乘除计算MulDiv

.版本 2
 
.DLL命令 乘除计算_, 整数型, "kernel32.dll", "MulDiv"
    .参数 乘数1, 整数型, , nNumber
    .参数 乘数2, 整数型, , nNumerator
    .参数 除数, 整数型, , nDenominator

易语言调用

.版本 2
 
.子程序 _按钮_乘除计算_被单击
 
编辑框_结果.内容 = 到文本 (乘除计算_ (到数值 (编辑框_乘数1.内容), 到数值 (编辑框_乘数2.内容), 到数值 (编辑框_乘数3.内容)))

发布日期:

所属分类: 易语言 标签: