RtlAdjustPrivilege 提升程序自身执行权限

RtlAdjustPrivilege函数

.版本 2
 
.DLL命令 RtlAdjustPrivilege, 整数型, "ntdll.dll", "RtlAdjustPrivilege", , 提升自身进程权限
    .参数 Privilege, 整数型, , 需要的权限,以SE_开头的常量,比如SE_DEBUG_PRIVILEGE表示提升到调试权限
    .参数 Enable, 逻辑型, , 如果为真(True)就是打开相应权限,如果为假(False)则是关闭相应权限
    .参数 CurrentThread, 整数型, , 如果为真(True)则仅提升当前线程权限,否则提升整个进程的权限
    .参数 RetEnable, 整数型, 传址, 输出原来相应权限的状态(打开 | 关闭)

RtlAdjustPrivilege进程提权ID对照表

SeCreateTokenPrivilege            0x2
SeAssignPrimaryTokenPrivilege     0x3
SeLockMemoryPrivilege             0x4
SeIncreaseQuotaPrivilege          0x5
SeUnsolicitedInputPrivilege       0x0
SeMachineAccountPrivilege         0x6
SeTcbPrivilege                    0x7
SeSecurityPrivilege               0x8
SeTakeOwnershipPrivilege          0x9
SeLoadDriverPrivilege             0xa
SeSystemProfilePrivilege          0xb
SeSystemtimePrivilege             0xc
SeProfileSingleProcessPrivilege   0xd
SeIncreaseBasePriorityPrivilege   0xe
SeCreatePagefilePrivilege         0xf
SeCreatePermanentPrivilege        0x10
SeBackupPrivilege                 0x11
SeRestorePrivilege                0x12
SeShutdownPrivilege               0x13
SeDebugPrivilege                  0x14
SeAuditPrivilege                  0x15
SeSystemEnvironmentPrivilege      0x16
SeChangeNotifyPrivilege           0x17
SeRemoteShutdownPrivilege         0x18
SeUndockPrivilege                 0x19
SeSyncAgentPrivilege              0x1a
SeEnableDelegationPrivilege       0x1b
SeManageVolumePrivilege           0x1c
SeImpersonatePrivilege            0x1d
SeCreateGlobalPrivilege           0x1e
SeTrustedCredManAccessPrivilege   0x1f
SeRelabelPrivilege                0x20
SeIncreaseWorkingSetPrivilege     0x21
SeTimeZonePrivilege               0x22
SeCreateSymbolicLinkPrivilege     0x23

常用公开

.版本 2
 
.常量 SE_BACKUP_PRIVILEGE, "17"
.常量 SE_RESTORE_PRIVILEGE, "18"
.常量 SE_SHUTDOWN_PRIVILEGE, "19"
.常量 SE_DEBUG_PRIVILEGE, "20"

易语言源码:

放到窗口创建完毕,首先调用。

.版本 2
 
' 提示进程权限
RtlAdjustPrivilege (20, 真, 假, 0)
 
.子程序 _拖放对象1_得到文件

发布日期:

所属分类: 易语言 标签: