易语言模块API视频教程窗口取类名(GetClassNameA)

API GetClassNameA

.版本 2

.DLL命令 GetClassNameA, 整数型, "user32", "GetClassNameA", , 为指定的窗口取得类名 以字节数表示的类名长度;排除最后的空中止字符。零表示出错。会设置GetLastError
.参数 窗口句柄, 整数型, , hWnd欲获得类名的那个窗口的句柄
.参数 缓冲区, 文本型, , IpClassName:指向接收窗口类名字符串的缓冲区的指针。随同类名载入的缓冲区。预先至少必须分配nMaxCount+1个字符
.参数 缓冲区长度, 整数型, , nMaxCount:指定由参数lpClassName指示的缓冲区的字节数。由lpClassName提供的缓冲区长度;

窗口取类名 模块源码

.版本 2

.子程序 窗口_取类名, 文本型, 公开, 取指定窗口的窗口类名,(成功返回出口类名,失败返回空文本)
.参数 窗口句柄, 整数型, , 要取得的窗口的句柄
.局部变量 类名, 文本型

类名 = 取空白文本 (50)
GetClassNameA (窗口句柄, 类名, 50)
返回 (类名)


发布日期:

所属分类: 易语言 标签: