易语言API模块制作文件取文件名

API --PathFindFileName

.版本 2

.DLL命令 PathFindFileNameA, 文本型, "shlwapi.dll", "PathFindFileNameA", , 文件_取文件名
.参数 pszPath, 文本型, , 文件完整路径

视频教程模块源码

.版本 2

.子程序 文件_取文件名, 文本型, 公开, 比如:F:\123.txt,成功返回123,失败返回空
.参数 路径文件名, 文本型, , 文件的完整路径包括名称
.参数 是否带后缀, 逻辑型, 可空, 默认为假,不带后缀,参数为真带后缀
.局部变量 j_fname, 文本型

j_fname = PathFindFileNameA (路径文件名)
.如果真 (取文本右边 (j_fname, 1) = “\”)
返回 (“”)
.如果真结束
返回 (选择 (是否带后缀, j_fname, 取文本左边 (j_fname, 取文本长度 (j_fname) - 取文本长度 (文件_取扩展名 (j_fname)))))


发布日期:

所属分类: 易语言 标签: