易语言查找相同文本源码

.版本 2
 
.子程序 查找相同文本
.参数 文本数组, 文本型, 数组
.参数 输出文本, 文本型, 数组
.局部变量 文本数量, 整数型
.局部变量 加入文本数量, 整数型
.局部变量 是否存在, 逻辑型
 
.计次循环首 (取数组成员数 (文本数组), 文本数量)
    .计次循环首 (取数组成员数 (输出文本), 加入文本数量)
        .如果真 (输出文本 [加入文本数量] = 文本数组 [文本数量])
            是否存在 = 真
            跳出循环 ()
        .如果真结束
 
    .计次循环尾 ()
    .如果真 (是否存在 = 假)
        加入成员 (输出文本, 文本数组 [文本数量])
    .如果真结束
    是否存在 = 假

发布日期:

所属分类: 易语言 标签: