易语言URLDownloadToFile下载URL文件

URLDownloadToFile

.版本 2
 
.DLL命令 URLDownloadToFile, 整数型, "Urlmon.dll", "URLDownloadToFileA"
    .参数 pCaller, 整数型
    .参数 szURL, 文本型
    .参数 szFileName, 文本型
    .参数 dwReserved, 整数型
    .参数 lpfnCB, 整数型

参数

参数名 类型 传址 数组 备注
LPUNKNOWN 整数型 控件的接口,如果不是控件则为0
LPCSTR 文本型 本参数指定欲读取文件在互联网上的HTTP地址(即URL),不能为空。
LPCSTR 文本型 下载后保存的文件名(包含路径).例如:c:\1.exe 保存在:c:\1.exe
DWORD 整数型 保留字段,必需为0
LPBINDSTATUSCALLBACK 整数型 一般为0

URLDownloadToFile封装

.版本 2
 
.子程序 API下载URL文件, 逻辑型, 公开
.参数 网络文件地址, 文本型
.参数 本地地址, 文本型
.局部变量 H, 整数型
 
H = API下载文件 (0, 网络文件地址, 本地地址, 0, 0)
.如果 (H = 0)
    返回 ()
.否则
    返回 ()

API下载URL文件调用

API下载 (“http://www.baidu.com”, “c:\1.html”)

发布日期:

所属分类: 易语言 标签: