大漠多线程循环任务自动切换模板-8判断账号登陆成功

判断账号登陆成功源码:

.版本 2
 
.子程序 模拟打怪
.参数 索引, 整数型
 
.判断开始 (线程 [索引].运行状态 > 0)
    .计次循环首 (10, )
        系统处理事件 ()
        线程 [索引].线程 [索引].dm.KeyPress (115)
        超级延时 (1000, )
    .计次循环尾 ()
 
.默认
.判断结束
 
.子程序 退出游戏
.参数 索引, 整数型
 
.判断开始 (线程 [索引].运行状态 > 0)
    系统处理事件 ()
    线程 [索引].线程 [索引].dm.MoveTo (646, 581)
    超级延时 (300, )
    线程 [索引].线程 [索引].dm.LeftClick ()
    超级延时 (2000, )
    线程 [索引].线程 [索引].dm.MoveTo (380, 225)
    超级延时 (300, )
    线程 [索引].线程 [索引].dm.LeftClick ()
    超级延时 (300, )
.默认
 
.判断结束
 
.子程序 是否出现游戏画面, 逻辑型
.参数 索引, 整数型
.局部变量 x, 整数型
.局部变量 y, 整数型
 
线程 [索引].dm.FindPic (0, 0, 2000, 2000, “开始.bmp”, “000000”, 0.9, 0, x, y)
.判断开始 (x > 0 且 y > 0)
    返回 ()
.默认
    返回 ()
.判断结束
 
.子程序 是否成功登录游戏, 逻辑型
.参数 索引, 整数型
.局部变量 x, 整数型
.局部变量 y, 整数型
 
线程 [索引].dm.FindPic (0, 0, 2000, 2000, “登录成功.bmp”, “000000”, 0.9, 0, x, y)
.判断开始 (x > 0 且 y > 0)
    返回 ()
.默认
    返回 ()
.判断结束


发布日期:

所属分类: 易语言 标签: