511遇见易语言多线程大漠多线程-29-免注册多线程大漠类模块制作及调用

多线程大漠类模块源码

.程序集 类多线程, , 公开
.程序集变量 obj, 对象, , "100"

.子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用

创建目录 (取运行目录 () + “\game”)
置文件属性 (取运行目录 () + “\game”, 2 + 4)
写到文件 (取运行目录 () + “\game\greg.dll”, #dmmreg)
置文件属性 (取运行目录 () + “\game\greg.dll”, 2 + 4)

.子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用

.子程序 初始化插件, , 公开
.参数 是否收费版, 逻辑型, 可空, 为空免费
.参数 索引, 整数型

.判断开始 (是否收费版)
写到文件 (取运行目录 () + “\game\dmsf.dll”, #dmsf)
置文件属性 (取运行目录 () + “\game\dmsf.dll”, 2 + 4 + 32)
SetDllPathA (取运行目录 () + “\game\dmsf.dll”, 0)
obj [索引].创建 (“dm.dmsoft”, )

.默认
写到文件 (取运行目录 () + “\game\dmmf.dll”, #dmmf)
置文件属性 (取运行目录 () + “\game\dmmf.dll”, 2 + 4 + 32)
SetDllPathA (取运行目录 () + “\game\dmmf.dll”, 0)
obj [索引].创建 (“dm.dmsoft”, )
.判断结束

.子程序 BindWindow, 整数型, 公开
.参数 hwnd, 整数型
.参数 display, 文本型
.参数 mouse, 文本型
.参数 keypad, 文本型
.参数 mode, 整数型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“BindWindow”, hwnd, display, mouse, keypad, mode))


发布日期:

所属分类: 易语言 标签: