易语言大漠找色命令

函数简介:

查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反

易语言用不了FindColor可以用此接口来代替

函数原型:

string FindColorE(x1, y1, x2, y2, color, sim, dir)

参数定义:

x1 整形数:区域的左上X坐标
y1 整形数:区域的左上Y坐标
x2 整形数:区域的右下X坐标
y2 整形数:区域的右下Y坐标
color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
sim 双精度浮点数:相似度,取值范围0.1-1.0
dir 整形数:查找方向 0: 从左到右,从上到下
1: 从左到右,从下到上
2: 从右到左,从上到下
3: 从右到左,从下到上
4:从中心往外查找
5: 从上到下,从左到右
6: 从上到下,从右到左
7: 从下到上,从左到右
8: 从下到上,从右到左

返回值:

字符串:
返回X和Y坐标 形式如"x|y", 比如"100|200"

示例:

pos = dm.FindColorE(0,0,2000,2000,"123456-000000|aabbcc-030303|ddeeff-202020",1.0,0)
pos = split(pos,"|")
If int(pos(0)) > 0 Then
    MessageBox "找到"
End If

易语言调用

.版本 2
.支持库 dm
 
.子程序 大漠_找色, 文本型
.参数 X1, 整数型
.参数 Y1, 整数型
.参数 X2, 整数型
.参数 Y2, 整数型
.参数 color, 文本型
.参数 sim, 双精度小数型
.参数 dir, 整数型
.局部变量 返回文本, 文本型
 
 
返回文本 = DM.FindColorE (X1, Y1, X2, Y2, color, sim, dir)
 
返回 (返回文本)

发布日期:

所属分类: 易语言 标签: