易语言大漠单线程模块制作使用系统字库找字

模块源码

.版本 2

.子程序 FindStrWithFont, 整数型, 公开, 在屏幕范围(x1,y1,x2,y2)内,查找string(可以是任意个字符串的组合)返回值:(返回字符串的索引 没找到返回-1, 比如"长安|洛阳",若找到长安,则返回0)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 string, 文本型, , string 字符串:待查找的字符串,可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
.参数 color_format, 文本型, , color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 注意,RGB和HSV格式都支持.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 font_name, 文本型, , 系统字体名称,比如“宋体”
.参数 font_size, 整数型, , font_size 整形数:系统字体尺寸,这个尺寸一定要以大漠综合工具获取的为准.如果获取尺寸看视频教程.
.参数 flag, 整数型, , 字体类别 取值可以是以下值的组合,比如1+2+4+8,2+4. 0表示正常字体
.参数 intX, 整数型, 参考, intX 变参指针:返回X坐标没找到返回-1
.参数 intY, 整数型, 参考, intY 变参指针:返回Y坐标没找到返回-1

返回 (obj.数值方法 (“FindStrWithFont”, x1, y1, x2, y2, string, color_format, sim, font_name, font_size, intX, intY))

.子程序 FindStrWithFontE, 文本型, 公开, 在屏幕范围(x1,y1,x2,y2)内,查找string(可以是任意个字符串的组合)返回值:(返回字符串序号以及X和Y坐标,形式如"id|x|y", 比如"0|100|200",没找到时,id和X以及Y均为-1,"-1|-1|-1")
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 string, 文本型, , string 字符串:待查找的字符串,可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
.参数 color_format, 文本型, , color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 注意,RGB和HSV格式都支持.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 font_name, 文本型, , 系统字体名称,比如“宋体”
.参数 font_size, 整数型, , font_size 整形数:系统字体尺寸,这个尺寸一定要以大漠综合工具获取的为准.如果获取尺寸看视频教程.
.参数 flag, 整数型, , 字体类别 取值可以是以下值的组合,比如1+2+4+8,2+4. 0表示正常字体

返回 (obj.数值方法 (“FindStrWithFontE”, x1, y1, x2, y2, string, color_format, sim, font_name, font_size))

.子程序 FindStrWithFontEx, 文本型, 公开, 在屏幕范围(x1,y1,x2,y2)内,查找string(可以是任意个字符串的组合)返回值:(返回所有找到的坐标集合,格式如下:"id,x0,y0|id,x1,y1|......|id,xn,yn")
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 string, 文本型, , string 字符串:待查找的字符串,可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
.参数 color_format, 文本型, , color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 注意,RGB和HSV格式都支持.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 font_name, 文本型, , 系统字体名称,比如“宋体”
.参数 font_size, 整数型, , font_size 整形数:系统字体尺寸,这个尺寸一定要以大漠综合工具获取的为准.如果获取尺寸看视频教程.
.参数 flag, 整数型, , 字体类别 取值可以是以下值的组合,比如1+2+4+8,2+4. 0表示正常字体

视频教程优酷土豆链接


发布日期:

所属分类: 易语言 标签: