易语言打开关闭混音设备

打开混合设备mixerOpen

.版本 2
 
.DLL命令 打开混合设备_, 整数型, "winmm.dll", "mixerOpen", , 打开混合设备
    .参数 混音设备句柄, 整数型, 传址, phmx,返回混音设备句柄 
    .参数 混音设备标识符, 整数型, , uMxId
    .参数 回调函数地址, 整数型, , dwCallback
    .参数 实例句柄, 整数型, , dwInstance
    .参数 打开句柄, 整数型, , fdwOpen
 
.DLL命令 关闭混合设备_, 整数型, "winmm.dll", "mixerClose"

关闭混合设备mixerClose

.版本 2
 
.DLL命令 关闭混合设备_, 整数型, "winmm.dll", "mixerClose"
    .参数 混音设备句柄, 整数型, , phmx

打开关闭混音设备源码

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮_打开关闭混音设备_被单击
.局部变量 局部_句柄, 整数型
 
打开混合设备_ (局部_句柄, 0, 0, 0, 0)
编辑框_运行结果.内容 = “混合设备句柄为:” + 到文本 (局部_句柄)
.判断开始 (关闭混合设备_ (局部_句柄)0)
    编辑框_运行结果.内容 = 编辑框_运行结果.内容 + “  混合设备关闭失败”
.默认
    编辑框_运行结果.内容 = 编辑框_运行结果.内容 + “  混合设备关闭成功”
.判断结束

发布日期:

所属分类: 易语言 标签: