511遇见易语言多线程大漠多线程-2中转子程序传多参

L-2 线程传参

线程启动(&子程序,整数参数,线程句柄)

分类原则:

(一)参数的多少

1、一个整数参数
2、多个整数参数
3、一个文本参数
4、多个文本参数
(二)传参方法
1、中转子程序
2、传入变量地址
3、传递内存地址
4、用数组传递参数
5、自定义
(三)总结:(多线程文本传参方式)
1.传入变量地址,适合单线程,多线程就容易出错。线程里面有可能还没取到数据,变量内容就有可能被主线程修改掉了。
2.将参数文本写到内存,传递内存地址到线程里面,程序偶尔直接崩溃。
3.用数组传递参数。这种方式感觉稳定性还可以,数据大占内存
课程源码:

.版本 2
.支持库 EThread
 
.子程序 _按钮1_被单击, , , 整数传参
.局部变量 n, 整数型
 
置随机数种子 ()
n = 取随机数 (1, 99999)
启动线程 (&子程序1, n, 线程句柄)
 
.子程序 子程序1
.参数 参_整数, 整数型
 
编辑框1.内容 = 到文本 (参_整数)
 
.子程序 __启动窗口_将被销毁
 
关闭线程句柄 (线程句柄)
.版本 2
.支持库 EThread
 
.子程序 _按钮1_被单击, , , 整数传参-多
 
启动线程 (&子程序2, , )
 
.子程序 子程序2, , , 中转子程序
 
子程序1 (编辑框2.内容, 编辑框3.内容, 编辑框4.内容)
 
.子程序 子程序1
.参数 账号, 文本型
.参数 密码, 文本型
.参数 验证码, 文本型
 
编辑框1.加入文本 (账号 + #换行符)
编辑框1.加入文本 (密码 + #换行符)
编辑框1.加入文本 (验证码 + #换行符)
.版本 2
.支持库 EThread
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击, , , 整数传参-多
 
启动线程 (&子程序2, , )
 
.子程序 子程序2, , , 中转子程序
 
子程序1 (500, 600, 1000)
 
.子程序 子程序1
.参数 a, 整数型
.参数 b, 整数型
.参数 c, 整数型
 
编辑框1.加入文本 (“a=” + 到文本 (a) + #换行符)
编辑框1.加入文本 (“b=” + 到文本 (b) + #换行符)
编辑框1.加入文本 (“c=” + 到文本 (c) + #换行符)


发布日期:

所属分类: 易语言 标签: