易语言教程倒找文本及实例

课程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 倒找文本-一个倒找--一个寻找
.局部变量 文本, 文本型
.局部变量 位置1
.局部变量 位置2

' 返回一个整数值,指定一文本在另一文本中最后出现的位置,位置值从 1 开始。如果未找到,返回-1。本命令为初级命令。
' 返回一个整数值,指定一文本在另一文本中最先出现的位置,位置值从 1 开始。如果未找到,返回-1。本命令为初级命令。
文本 = “1234563789”
位置1 = 倒找文本 (文本, “3”, , 假)
位置2 = 寻找文本 (文本, “3”, , 假)
调试输出 (位置1)
调试输出 (位置2)
调试输出 (取文本中间 (文本, 位置2 + 1, 位置1 - 位置2 - 1))

.子程序 _按钮2_被单击, , , 倒找文本-两个寻找
.局部变量 文本, 文本型
.局部变量 位置1
.局部变量 位置2

文本 = “1234563789”
位置1 = 寻找文本 (文本, “3”, , 假)
位置2 = 寻找文本 (文本, “3”, 位置1 + 1, 假)
调试输出 (位置1)
调试输出 (位置2)
调试输出 (取文本中间 (文本, 位置1 + 1, 位置2 - 位置1 - 1))

.子程序 _按钮3_被单击, , , 倒找文本-3--两个倒找文本
.局部变量 文本, 文本型
.局部变量 位置1
.局部变量 位置2

文本 = “1234563789”
位置1 = 倒找文本 (文本, “3”, , 假)
位置2 = 倒找文本 (文本, “3”, 位置1 - 1, 假)
调试输出 (位置1)
调试输出 (位置2)
调试输出 (取文本中间 (文本, 位置2 + 1, 位置1 - 位置2 - 1))

.子程序 _按钮4_被单击, , , 倒找文本-4--取文本左边和右边的组合
.局部变量 文本, 文本型
.局部变量 位置1
.局部变量 文本左边, 文本型
.局部变量 文本右边, 文本型
.局部变量 字符总数

文本 = “D:\游戏\剑侠\剑侠情缘网络版\gamefree.exe”
位置1 = 倒找文本 (文本, “\”, , 假)
字符总数 = 取文本长度 (文本)
文本左边 = 取文本左边 (文本, 位置1)
文本右边 = 取文本右边 (文本, 字符总数 - 位置1)
' 信息框 (文本左边, 0, , )
信息框 (文本右边, 0, , )

.子程序 _按钮5_被单击, , , 倒找文本-5
.局部变量 文本, 文本型
.局部变量 结果, 文本型

文本 = “ABCDEFGHIJKLMN”
.判断循环首 (取文本长度 (文本) > 0)
结果 = 结果 + 取文本右边 (文本, 1)
文本 = 取文本左边 (文本, 取文本长度 (文本) - 1)
.判断循环尾 ()
调试输出 (结果)
信息框 (结果, 0, , )


发布日期:

所属分类: 易语言 标签: