易语言教程寻找文本及实例

教程源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 寻找文本
.局部变量 被寻找的文本, 文本型
.局部变量 欲寻找的文本, 文本型
.局部变量 返回的文本位置

被寻找的文本 = 删全部空 (编辑框1.内容)
欲寻找的文本 = 删全部空 (编辑框2.内容)
返回的文本位置 = 寻找文本 (被寻找的文本, 欲寻找的文本, , 真)
编辑框3.内容 = #左引号 + 欲寻找的文本 + #右引号 + “ 的位置” + 到文本 (返回的文本位置)

.子程序 _按钮2_被单击, , , 多次寻找文本(非汉字)
.局部变量 被寻找的文本, 文本型
.局部变量 欲寻找的文本, 文本型
.局部变量 i
.局部变量 计次

被寻找的文本 = 删全部空 (编辑框1.内容)
欲寻找的文本 = 删全部空 (编辑框2.内容)
i = 寻找文本 (被寻找的文本, 欲寻找的文本, , 真)
.判断循环首 (i > -1)
计次 = 计次 + 1
信息框 (“第” + 到文本 (计次) + “个” + #左引号 + 欲寻找的文本 + #右引号 + “的位置: ” + 到文本 (i), 0, , )
i = 寻找文本 (被寻找的文本, 欲寻找的文本, i + 1, 真)
.判断循环尾 ()
编辑框3.内容 = “共找到 ” + 到文本 (计次) + “次” + 欲寻找的文本

.子程序 _按钮3_被单击, , , 多次寻找文本-汉字
.局部变量 被寻找的文本, 字节集
.局部变量 欲寻找的文本, 字节集
.局部变量 i
.局部变量 计次

被寻找的文本 = 到字节集 (删全部空 (编辑框1.内容))
欲寻找的文本 = 到字节集 (删全部空 (编辑框2.内容))
i = 寻找字节集 (被寻找的文本, 欲寻找的文本, )
.判断循环首 (i > -1)
计次 = 计次 + 1
信息框 (“第” + 到文本 (计次) + “个” + #左引号 + 到文本 (欲寻找的文本) + #右引号 + “的位置: ” + 到文本 (i), 0, , )
i = 寻找字节集 (被寻找的文本, 欲寻找的文本, i + 1)
.判断循环尾 ()
编辑框3.内容 = “共找到 ” + 到文本 (计次) + “次” + 到文本 (欲寻找的文本)


发布日期:

所属分类: 易语言 标签: