易语言大漠单线程模块制作窗口2获取窗口句柄类

模块源码

.版本 2

.子程序 FindWindow, 整数型, 公开, 查找符合类名或者标题名的顶层可见窗口FindWindow(找到返回窗口句柄,没找到返回0)
.参数 class, 文本型, 可空, 窗口类名,如果为空,则匹配所有. 这里的匹配是模糊匹配.
.参数 title, 文本型, 可空, 窗口标题,如果为空,则匹配所有.这里的匹配是模糊匹配.

返回 (obj.数值方法 (“FindWindow”, class, title))

.子程序 FindWindowByProcess, 整数型, 公开, 根据指定的进程名字,来查找可见窗口.FindWindowByProcess(找到返回窗口句柄,没找到返回0)
.参数 process_name, 文本型, , 进程名. 比如(notepad.exe).这里是精确匹配,但不区分大小写.
.参数 class, 文本型, 可空, 窗口类名,如果为空,则匹配所有. 这里的匹配是模糊匹配.
.参数 title, 文本型, 可空, 窗口标题,如果为空,则匹配所有.这里的匹配是模糊匹配.

返回 (obj.数值方法 (“FindWindowByProcess”, process_name, class, title))

.子程序 FindWindowByProcessId, 整数型, 公开, 根据指定的进程Id,来查找可见窗口.FindWindowByProcessId(找到返回窗口句柄,没找到返回0)
.参数 process_id, 整数型, , 进程id.
.参数 class, 文本型, 可空, 窗口类名,如果为空,则匹配所有. 这里的匹配是模糊匹配.
.参数 title, 文本型, 可空, 窗口标题,如果为空,则匹配所有. 这里的匹配是模糊匹配.

返回 (obj.数值方法 (“FindWindowByProcessId”, process_id, class, title))

.子程序 FindWindowEx, 整数型, 公开, 查找符合类名或者标题名的顶层可见窗口,如果指定了parent,则在parent的第一层子窗口中查找.FindWindowEx(找到返回窗口句柄,没找到返回0)
.参数 parent, 整数型, 可空, 父窗口句柄,如果为空,则匹配所有顶层窗口
.参数 class, 文本型, 可空, 窗口类名,如果为空,则匹配所有. 这里的匹配是模糊匹配.
.参数 title, 文本型, 可空, 窗口标题,如果为空,则匹配所有. 这里的匹配是模糊匹配.

返回 (obj.数值方法 (“FindWindowEx”, parent, class, title))

.子程序 FindWindowSuper, 整数型, 公开, 根据两组设定条件来查找指定窗口.FindWindowSuper(找到返回窗口句柄,没找到返回0)
.参数 spec1, 文本型, , spec1 字符串: 查找串1. (内容取决于flag1的值)
.参数 flag1, 整数型, , 0表示spec1的内容是标题1;表示spec1的内容是程序名字. (比如notepad);2表示spec1的内容是类名,3,4,5,6,7,8,9详见接口说明
.参数 type1, 整数型, , 0精确判断;1模糊判断
.参数 spec2, 文本型, , 查找串2. (内容取决于flag2的值)
.参数 flag2, 整数型, , 0表示spec2的内容是标题1;表示spec2的内容是程序名字. (比如notepad);2表示spec2的内容是类名,3,4,5,6,7,8,9详见接口说明
.参数 type2, 整数型, , 0精确判断;1模糊判断

返回 (obj.数值方法 (“FindWindowSuper”, spec1, flag1, type1, spec2, flag2, type2))

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: