易语言大漠单线程模块制作窗口-1

模块源码

.版本 2
 
.子程序 ClientToScreen, 整数型, 公开, 把窗口坐标转换为屏幕坐标ClientToScreen(返回值:0失败,1成功)
.参数 hwnd, 整数型, , 指定的窗口句柄
.参数 x, 整数型, 参考, 窗口X坐标
.参数 y, 整数型, 参考, 窗口Y坐标
 
返回 (obj.数值方法 (“ClientToScreen”, hwnd, x, y))
 
.子程序 EnumProcess, 文本型, 公开, 根据指定进程名,枚举系统中符合条件的进程PIDEnumProcess(返回所有匹配的进程PID,并按打开顺序排序,格式"pid1,pid2,pid3")
.参数 name, 文本型, , 进程名,比如qq.exe
 
返回 (obj.文本方法 (“EnumProcess”, name))
 
.子程序 EnumWindow, 文本型, 公开, 根据指定条件,枚举系统中符合条件的窗口EnumWindow(返回所有匹配的窗口句柄字符串,格式"hwnd1,hwnd2,hwnd3")
.参数 parent, 整数型, , 获得的窗口句柄是该窗口的子窗口的窗口句柄,0时为获得桌面句柄
.参数 title, 文本型, , 窗口标题. 此参数是模糊匹配.
.参数 class_name, 文本型, , 窗口类名. 此参数是模糊匹配.
.参数 filter, 整数型, , 1+4+8+161 : 匹配窗口标题,参数title有效 2 : 匹配窗口类名,参数class_name有效 4 : 只匹配指定父窗口的第一层孩子窗口...)
 
返回 (obj.文本方法 (“EnumWindow”, parent, title, class_name, filter))
 
.子程序 EnumWindowByProcess, 文本型, 公开, 根据指定进程以及其它条件,枚举系统中符合条件的窗口EnumWindowByProcess(返回所有匹配的窗口句柄字符串,格式"hwnd1,hwnd2,hwnd3")
.参数 process_name, 文本型, , 进程映像名.比如(svchost.exe). 此参数是精确匹配,但不区分大小写.
.参数 title, 文本型, , 窗口标题. 此参数是模糊匹配.
.参数 class_name, 文本型, , 窗口类名. 此参数是模糊匹配.
.参数 filter, 整数型, , 1+4+8+161 : 匹配窗口标题,参数title有效 2 : 匹配窗口类名,参数class_name有效 4 : 只匹配指定父窗口的第一层孩子窗口...)
 
返回 (obj.文本方法 (“EnumWindowByProcess”, process_name, title, class_name, filter))
 
.子程序 EnumWindowByProcessId, 文本型, 公开, 根据指定进程pid以及其它条件,枚举系统中符合条件的窗口EnumWindowByProcessId(返回所有匹配的窗口句柄字符串,格式"hwnd1,hwnd2,hwnd3")
.参数 pid, 整数型, , 进程pid.
.参数 title, 文本型, , 窗口标题. 此参数是模糊匹配.
.参数 class_name, 文本型, , 窗口类名. 此参数是模糊匹配.
.参数 filter, 整数型, , 1 : 匹配窗口标题,参数title有效;2 : 匹配窗口类名,参数class_name有效;8 : 匹配所有者窗口为0的窗口,即顶级窗口;16 : 匹配可见的窗口比如2+8+16
 
返回 (obj.文本方法 (“EnumWindowByProcessId”, pid, title, class_name, filter))
 
.子程序 EnumWindowSuper, 文本型, 公开, 根据两组设定条件来枚举指定窗口.EnumWindowSuper(返回所有匹配的窗口句柄字符串,格式"hwnd1,hwnd2,hwnd3")
.参数 spec1, 文本型, , 查找串1. (内容取决于flag1的值)
.参数 flag1, 整数型, , 0表示spec1的内容是标题;1表示spec1的内容是程序名字. (比如notepad);2表示spec1的内容是类名,3456789详见接口说明
.参数 type1, 整数型, , 0精确判断;1模糊判断
.参数 spec2, 文本型, , 查找串2. (内容取决于flag2的值)
.参数 flag2, 整数型, , 0表示spec2的内容是标题,1表示spec2的内容是程序名字. (比如notepad)23456789详见接口说明
.参数 type2, 整数型, , 0精确判断;1模糊判断
.参数 sort, 整数型, , 0不排序.1对枚举出的窗口进行排序,按照窗口打开顺序.
 
返回 (obj.文本方法 (“EnumWindowSuper”, spec1, flag1, type1, spec2, flag2, type2, sort))

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: