易语言大漠单线程模块制作后台找字FindStrFast

FindStrFast大漠文档接口说明

函数简介:
同FindStr。
函数原型:
long FindStrFast(x1,y1,x2,y2,string,color_format,sim,intX,intY)
参数定义:
 
x1 整形数:区域的左上X坐标
y1 整形数:区域的左上Y坐标
x2 整形数:区域的右下X坐标
y2 整形数:区域的右下Y坐标
string 字符串:待查找的字符串,可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 具体可以查看下面的示例.注意,RGB和HSV格式都支持.
sim 双精度浮点数:相似度,取值范围0.1-1.0
intX 变参指针:返回X坐标 没找到返回-1
intY 变参指针:返回Y坐标 没找到返回-1
 
返回值:
整形数:
返回字符串的索引 没找到返回-1, 比如"长安|洛阳",若找到长安,则返回0
 
示例:
dm_ret = dm.FindStrFast(0,0,2000,2000,"长安","9f2e3f-000000",1.0,intX,intY)
If intX >= 0 and intY >= 0 Then
     dm.MoveTo intX,intY
End If 
dm_ret = dm.FindStrFast(0,0,2000,2000,"长安|洛阳","9f2e3f-000000",0.9,intX,intY)
If intX >= 0 and intY >= 0 Then
     dm.MoveTo intX,intY
End If
 
// 查找时,对多行文本进行换行,换行分隔符是"|". 语法是在","后增加换行字符串.任意字符串都可以.
dm_ret = dm.FindStrFast(0,0,2000,2000,"长安|洛阳","9f2e3f-000000,|",0.9,intX,intY)
If intX >= 0 and intY >= 0 Then
     dm.MoveTo intX,intY
End If 
 
注: 此函数比FindStr要快很多,尤其是在字库很大时,或者模糊识别时,效果非常明显。
推荐使用此函数。
另外由于此函数是只识别待查找的字符,所以可能会有如下情况出现问题。
 
比如 字库中有"张和三" 一共3个字符数据,然后待识别区域里是"张和三",如果用FindStr查找
"张三"肯定是找不到的,但是用FindStrFast却可以找到,因为"和"这个字符没有列入查找计划中
所以,在使用此函数时,也要特别注意这一点。

视频模块源码:

.版本 2
 
.子程序 FindStrFast, 整数型, 公开, 在屏幕范围(x1,y1,x2,y2),查找string(可以是任意个字符串的组合)返回值:(返回字符串的索引 没找到返回-1, 比如"长安|洛阳",若找到长安,则返回0)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 string, 文本型, , string 字符串:待查找的字符串,可以是字符串组合,比如"长安|洛阳|大雁塔",中间用"|"来分割字符串
.参数 color_format, 文本型, , color_format 字符串:颜色格式串, 可以包含换行分隔符,语法是","后加分割字符串. 注意,RGB和HSV格式都支持.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 intX, 整数型, 参考, intX 变参指针:返回X坐标没找到返回-1
.参数 intY, 整数型, 参考, intY 变参指针:返回Y坐标没找到返回-1
 
返回 (obj.数值方法 (“FindStrFast”, x1, y1, x2, y2, string, color_format, sim, intX, intY))

《剑侠情缘》测试源码

.版本 2
 
.子程序 _按钮9_被单击, , , FindStrFast
.局部变量 x, 整数型
.局部变量 y, 整数型
.局部变量 tmp, 整数型
 
tmp = FindStrFast (0, 0, 2000, 2000, “天盾|鬼谷|墨攻|尚贤”, “ebb200-000000”, 0.9, x, y)
.如果 (x ≥ 0)
    MoveTo (x, y)
    延时 (100)
    LeftClick ()
.否则

视频教程优酷土豆链接


发布日期:

所属分类: 易语言 标签: