易语言大漠模块制作教程查找颜色FindColor

视频教程源码:

.版本 2

.子程序 FindColor, 整数型, 公开, 查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;返回值:(0:没找到;1:找到)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 文本型, , color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 dir, 整数型, , dir 整形数:查找方向 0: 从左到右,从上到下;1: 从左到右,从下到上;2: 从右到左,从上到下;3: 从右到左,从下到上;4:从中心往外查找;5: 从上到下,从左到右;6: 从上到下,从右到左;7: 从下到上,从左到右;8: 从下到上,从右到左
.参数 intX, 整数型, 参考, intX 变参指针:返回X坐标
.参数 intY, 整数型, 参考, intY 变参指针:返回Y坐标

返回 (obj.数值方法 (“FindColor”, x1, y1, x2, y2, color, sim, dir, intX, intY))

.子程序 FindColorBlock, 整数型, 公开, 查找指定区域内的颜色块,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;返回值:(0:没找到;1:找到)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 文本型, , color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 count, 整数型, , count整形数:在宽度为width,高度为height的颜色块中,符合color颜色的最小数量.(注意,这个颜色数量可以在综合工具的二值化区域中看到)
.参数 width, 整数型, , width 整形数:颜色块的宽度
.参数 height, 整数型, , height 整形数:颜色块的高度
.参数 intX, 整数型, 参考, intX 变参指针:返回X坐标(指向颜色块的左上角)
.参数 intY, 整数型, 参考, intY 变参指针:返回Y坐标(指向颜色块的左上角)

返回 (obj.数值方法 (“FindColorBlock”, x1, y1, x2, y2, color, sim, count, width, height, intX, intY))

.子程序 FindColorBlockEx, 文本型, 公开, 查找指定区域内的颜色块,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;返回值:(返回所有颜色块信息的坐标值,然后通过GetResultCount等接口来解析 (由于内存限制,返回的颜色数量最多为1800个左右))
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 文本型, , color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 count, 整数型, , count整形数:在宽度为width,高度为height的颜色块中,符合color颜色的最小数量.(注意,这个颜色数量可以在综合工具的二值化区域中看到)
.参数 width, 整数型, , width 整形数:颜色块的宽度
.参数 height, 整数型, , height 整形数:颜色块的高度

返回 (obj.文本方法 (“FindColorBlockEx”, x1, y1, x2, y2, color, sim, count, width, height))

.子程序 FindColorE, 文本型, 公开, 查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;易语言用不了FindColor可以用此接口来代替;返回值:(返回X和Y坐标 形式如"x|y", 比如"100|200")
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 文本型, , color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 dir, 整数型, , dir 整形数:查找方向 0: 从左到右,从上到下;1: 从左到右,从下到上;2: 从右到左,从上到下;3: 从右到左,从下到上;4:从中心往外查找;5: 从上到下,从左到右;6: 从上到下,从右到左;7: 从下到上,从左到右;8: 从下到上,从右到左

返回 (obj.文本方法 (“FindColorE”, x1, y1, x2, y2, color, sim, dir))

.子程序 FindColorEx, 文本型, 公开, 查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;易语言用不了FindColor可以用此接口来代替;返回值:(返回所有颜色信息的坐标值,然后通过GetResultCount等接口来解析 (由于内存限制,返回的颜色数量最多为1800个左右))
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 文本型, , color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 dir, 整数型, , dir 整形数:查找方向 0: 从左到右,从上到下;1: 从左到右,从下到上;2: 从右到左,从上到下;3: 从右到左,从下到上;4:从中心往外查找;5: 从上到下,从左到右;6: 从上到下,从右到左;7: 从下到上,从左到右;8: 从下到上,从右到左

返回 (obj.文本方法 (“FindColorEx”, x1, y1, x2, y2, color, sim, dir))

.子程序 FindMulColor, 整数型, 公开, 查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;返回值:(0:没找到或者部分颜色没找到;1:所有颜色都找到)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 文本型, , color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0

返回 (obj.数值方法 (“FindMulColor”, x1, y1, x2, y2, color, sim))

.子程序 FindMultiColor, 整数型, 公开, 查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;返回值:(0:没找到;1:找到)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 first_color, 文本型, , 颜色格式为"RRGGBB-DRDGDB|RRGGBB-DRDGDB|…………",比如"123456-000000"
.参数 offset_color, 文本型, , 偏移颜色可以支持任意多个点 格式和按键自带的Color插件意义相同, 只不过我的可以支持偏色和多种颜色组合
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 dir, 整数型, , dir 整形数:查找方向 0: 从左到右,从上到下 1: 从左到右,从下到上 2: 从右到左,从上到下 3: 从右到左, 从下到上
.参数 intX, 整数型, 参考, 返回X坐标(坐标为first_color所在坐标)
.参数 intY, 整数型, 参考, 返回Y坐标(坐标为first_color所在坐标)

返回 (obj.数值方法 (“FindMultiColor”, x1, y1, x2, y2, first_color, offset_color, sim, dir, intX, intY))

.子程序 FindMultiColorE, 文本型, 公开, 查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反易语言用不了FindMultiColor可以用此接口来代替;返回值:(返回X和Y坐标 形式如"x|y", 比如"100|200")
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 first_color, 文本型, , 颜色格式为"RRGGBB-DRDGDB|RRGGBB-DRDGDB|…………",比如"123456-000000"
.参数 offset_color, 文本型, , 偏移颜色可以支持任意多个点 格式和按键自带的Color插件意义相同, 只不过我的可以支持偏色和多种颜色组合
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 dir, 整数型, , dir 整形数:查找方向 0: 从左到右,从上到下 1: 从左到右,从下到上 2: 从右到左,从上到下 3: 从右到左, 从下到上

返回 (obj.文本方法 (“FindMultiColorE”, x1, y1, x2, y2, first_color, offset_color, sim, dir))

.子程序 FindMultiColorEx, 文本型, 公开, 查找指定区域内的颜色,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反易语言用不了FindMultiColor可以用此接口来代替;返回值:(返回所有颜色信息的坐标值,然后通过GetResultCount等接口来解析(由于内存限制,返回的坐标数量最多为1800个左右;坐标是first_color所在的坐标)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 first_color, 文本型, , 颜色格式为"RRGGBB-DRDGDB|RRGGBB-DRDGDB|…………",比如"123456-000000"
.参数 offset_color, 文本型, , 偏移颜色可以支持任意多个点 格式和按键自带的Color插件意义相同, 只不过我的可以支持偏色和多种颜色组合
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0
.参数 dir, 整数型, , dir 整形数:查找方向 0: 从左到右,从上到下 1: 从左到右,从下到上 2: 从右到左,从上到下 3: 从右到左, 从下到上

返回 (obj.文本方法 (“FindMultiColorEx”, x1, y1, x2, y2, first_color, offset_color, sim, dir))

视频教程链接:


发布日期:

所属分类: 易语言 标签: