易语言教程取字节集左边中间右边

取字节集左边

调用格式: 〈字节集〉 取字节集左边 (字节集 欲取其部分的字节集,整数型 欲取出字节的数目) - 系统核心支持库->字节集操作
英文名称:BinLeft
返回一个字节集,其中包含指定字节集中从左边算起指定数量的字节。本命令为初级命令。
参数<1>的名称为“欲取其部分的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“欲取出字节的数目”,类型为“整数型(int)”。

操作系统需求: Windows、Linux

取字节集中间

调用格式: 〈字节集〉 取字节集中间 (字节集 欲取其部分的字节集,整数型 起始取出位置,整数型 欲取出字节的数目) - 系统核心支持库->字节集操作
英文名称:BinMid
返回一个字节集,其中包含指定字节集中从指定位置算起指定数量的字节。本命令为初级命令。
参数<1>的名称为“欲取其部分的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“起始取出位置”,类型为“整数型(int)”。1为首位置,2为第2个位置,如此类推。
参数<3>的名称为“欲取出字节的数目”,类型为“整数型(int)”。

操作系统需求: Windows、Linux

取字节集右边

调用格式: 〈字节集〉 取字节集右边 (字节集 欲取其部分的字节集,整数型 欲取出字节的数目) - 系统核心支持库->字节集操作
英文名称:BinRight
返回一个字节集,其中包含指定字节集中从右边算起指定数量的字节。本命令为初级命令。
参数<1>的名称为“欲取其部分的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“欲取出字节的数目”,类型为“整数型(int)”。

操作系统需求: Windows、Linux

视频教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 取字节集左边
.局部变量 字节集变量, 字节集
.局部变量 取出的字节集, 字节集

字节集变量 = 到字节集 (“易语言全中文编程语言”)
取出的字节集 = 取字节集左边 (字节集变量, 4)
调试输出 (取出的字节集)
编辑框1.内容 = 到文本 (取出的字节集)

.子程序 _按钮2_被单击, , , 取字节集右边
.局部变量 字节集变量, 字节集
.局部变量 取出的字节集, 字节集

字节集变量 = 到字节集 (“易语言全中文编程语言”)
取出的字节集 = 取字节集右边 (字节集变量, 6)
调试输出 (取出的字节集)
编辑框1.内容 = 到文本 (取出的字节集)

.子程序 _按钮3_被单击, , , 取字节集中间
.局部变量 字节集变量, 字节集
.局部变量 取出的字节集, 字节集

字节集变量 = 到字节集 (“易语言全中文编程语言”)
取出的字节集 = 取字节集中间 (字节集变量, 7, 6)
调试输出 (取出的字节集)
编辑框1.内容 = 到文本 (取出的字节集)


发布日期:

所属分类: 易语言 标签: