易语言列表框去重复项目到列表框

视频教程截图

511遇见

易语言列表框去重复项目到列表框视频教程源码:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

皮肤_加载 (1)

.子程序 _按钮1_被单击
.局部变量 项目文本, 文本型

项目文本 = 列表框1.取项目文本 (列表框1.现行选中项)
.如果 (列表框查找文本 (列表框2, 项目文本) = 真)
列表框2.加入项目 (项目文本, )
.否则

.如果结束

.子程序 列表框查找文本, 逻辑型
.参数 列表框, 列表框
.参数 要加入的文本, 文本型
.局部变量 I, 整数型

.计次循环首 (列表框.取项目数 (), I)
.如果真 (要加入的文本 = 列表框.取项目文本 (I - 1))
返回 (假)
.如果真结束

.计次循环尾 ()
返回 (真)

.子程序 _按钮2_被单击
.局部变量 列表框1内容, 文本型

列表框1内容 = 列表框1.取项目文本 (列表框1.现行选中项)
.如果 (列表框2.选择 (列表框1内容) = -1)
列表框2.加入项目 (列表框1内容, )
.否则

.如果结束

.子程序 _按钮3_被单击
.局部变量 项目, 文本型

项目 = 列表框1.取项目文本 (列表框1.现行选中项)

.如果 (列表框加入项目 (列表框2, 项目) = 真)
信息框 (“项目添加成功”, 0, , )
.否则

.如果结束

.子程序 列表框加入项目, 逻辑型
.参数 列表框, 列表框
.参数 要加入的文本, 文本型
.局部变量 n, 整数型

.计次循环首 (列表框.取项目数 (), n)
.如果真 (要加入的文本 = 列表框.取项目文本 (n - 1))
返回 (假)
.如果真结束

.计次循环尾 ()
列表框.加入项目 (要加入的文本, )
返回 (真)

.子程序 _按钮4_被单击
.局部变量 项目, 文本型

项目 = 列表框1.取项目文本 (列表框1.现行选中项)
.如果 (SendMessageA (列表框2.取窗口句柄 (), 399, 0, 项目) = -1)
列表框2.加入项目 (项目, )
信息框 (“项目添加成功!”, 0, , )

.否则
信息框 (“已经存主【” + 项目 + “】请不要重复添加!”, 16, , )

.如果结束

教程下载:


发布日期:

所属分类: 易语言 标签: