大漠多线程循环任务自动切换模板-2读取账号到超级列表框

文本多账号格式

窗口1
abcde-1----111111
abcde-2----222222
abcde-3----333333
abcde-4----444444
abcde-5----555555
abcde-6----666666
窗口2
fghjk-1----777777
fghjk-2----888888
fghjk-3----999999
fghjk-4----121212
fghjk-5----343434
fghjk-6----565656
窗口3
qwert-1----787878

读取游戏账号到超级列表框源码:

.版本 2
.支持库 iext

.子程序 读取账号, , , 读取账号到列表框
.局部变量 ftext, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 ctext, 文本型, , "0"
.局部变量 n, 整数型
.局部变量 number, 文本型, , "0"

窗口列表.全部删除 ()
ftext = 分割文本 (读入文本 (打开文件 (取运行目录 () + “\user.txt”, , ), ), “窗口”, )
.计次循环首 (取数组成员数 (ftext), i)
.判断开始 (i + 1 > 取数组成员数 (ftext))
跳出循环 ()
.判断 (ftext [i + 1] = “”)
跳出循环 ()
.默认
ctext = 分割文本 (ftext [i + 1], #换行符, )
.判断开始 (取数组成员数 (ctext) < 2)
跳出循环 ()

.判断 (ctext [2] ≠ “”)
窗口列表.插入表项 (, , , , , )
窗口列表.置标题 (i - 1, 0, ctext [1])

.计次循环首 (取数组成员数 (ctext), n)
.判断开始 (n + 1 > 取数组成员数 (ctext))
跳出循环 ()
.判断 (ctext [n + 1] = “”)
跳出循环 ()
.判断 (窗口列表.取标题 (i - 1, 8) ≠ “”)
窗口列表.置标题 (i - 1, 8, 窗口列表.取标题 (i - 1, 8) + “|” + ctext [n + 1])

.默认
窗口列表.置标题 (i - 1, 8, ctext [n + 1])
.判断结束

number = 分割文本 (窗口列表.取标题 (i - 1, 8), “|”, )
窗口列表.置标题 (i - 1, 6, 到文本 (取数组成员数 (number)))

.计次循环尾 ()

.默认

.判断结束
.判断结束

.计次循环尾 ()
关闭所有文件 ()
重定义数组 (线程, 假, 窗口列表.取表项数 ())


发布日期:

所属分类: 易语言 标签: