易语言组合框自定义数据类型二级联动

教程截图

511遇见

组合框列表项被选择源码:

.版本 2

.局部变量 i, 整数型
.局部变量 当前省, 文本型

当前省 = 组合框1.取项目文本 (组合框1.现行选中项)
组合框2.清空 ()
编辑框2.内容 = “”
编辑框2.加入文本 (“你选择了:” + 组合框1.取项目文本 (组合框1.现行选中项) + “省” + #换行符)

.计次循环首 (取数组成员数 (所有城市), i)
.如果真 (所有城市 [i].省份 = 当前省)
组合框2.加入项目 (所有城市 [i].城市, i)
.如果真结束

.计次循环尾 ()
组合框2.现行选中项 = 0
编辑框2.加入文本 (“该省共有:” + 到文本 (组合框2.取项目数 ()) + “地区” + #换行符 + “地区分布:”)
.计次循环首 (取数组成员数 (所有城市), i)
.如果真 (所有城市 [i].省份 = 当前省)
编辑框2.加入文本 (所有城市 [i].地区 + “;”)
.如果真结束

.计次循环尾 ()
_组合框2_列表项被选择 ()

窗口创建完毕初始化源码:

.版本 2

.局部变量 当前城市, 城市
.局部变量 所有省份, 字节集
.局部变量 当前省份, 字节集
.局部变量 省份个数, 整数型
.局部变量 i, 整数型
.局部变量 城市列表, 文本型, , "0"

城市列表 = 取配置节名 (取运行目录 () + “\data.ini”)

.计次循环首 (取数组成员数 (城市列表), i)
当前城市.id = 到整数 (城市列表 [i])
当前城市.城市 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “城市”, )
当前城市.地区 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “地区”, )
当前城市.省份 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “省份”, )
加入成员 (所有城市, 当前城市)

当前省份 = 到字节集 (取文本长度 (当前城市.省份)) + 到字节集 (当前城市.省份)

.如果真 (寻找字节集 (所有省份, 当前省份, ) = -1)
所有省份 = 所有省份 + 当前省份

省份个数 = 省份个数 + 1

.如果真结束
跳过 ()
.计次循环尾 ()
组合框1.列表项目 = 取字节集左边 (到字节集 (省份个数), 2) + 所有省份

自定义数据类型

.版本 2
 
.数据类型 城市
    .成员 id, 整数型
    .成员 城市, 文本型
    .成员 地区, 文本型
    .成员 省份, 文本型

配置文件Data.ini

[1]
城市=昌平
地区=青岛
省份=山东
[2]
城市=平邑
地区=临沂
省份=山东
[3]
城市=长清
地区=济南
省份=山东
[4]
城市=滕州
地区=枣庄
省份=山东
[5]
城市=莱山
地区=烟台
省份=山东
[6]
城市=利津
地区=东营
省份=山东
[7]
城市=寿光
地区=潍坊
省份=山东
[8]
城市=曲阜
地区=济宁
省份=山东
[9]
城市=新泰
地区=泰安
省份=山东
[10]
城市=荣成
地区=威海
省份=山东
[11]
城市=莒县
地区=日照
省份=山东
[12]
城市=邹平
地区=滨州
省份=山东
[13]
城市=夏津
地区=德州
省份=山东
[14]
城市=临清
地区=聊城
省份=山东
[15]
城市=巨野
地区=菏泽
省份=山东
[16]
城市=阳曲
地区=太原
省份=山西
[17]
城市=左云
地区=大同
省份=山西
[18]
城市=应县
地区=朔州
省份=山西
[19]
城市=盂县
地区=阳泉
省份=山西
[20]
城市=平顺
地区=长治
省份=山西
[21]
城市=泽州
地区=晋城
省份=山西
[22]
城市=五台
地区=忻州
省份=山西
[23]
城市=文水
地区=吕梁
省份=山西
[24]
城市=平遥
地区=晋中
省份=山西
[25]
城市=洪洞
地区=临汾
省份=山西
[26]
城市=夏县
地区=运城
省份=山西
[27]
城市=河曲
地区=忻州
省份=山西

教程下载:


发布日期:

所属分类: 易语言 标签: