组合框读取ACCESS数据库MDB实现联动

教程截图

511遇见

组合框读取ACCESS数据库MDB实现联动源码:

.版本 2
.支持库 spec
.支持库 eDB
调试输出 (数据库连接1.连接Access (取运行目录 () + “\db1.mdb”, “”))
调试输出 (记录集1.置连接 (数据库连接1))
调试输出 (记录集1.打开 (“select  * from 表1, #SQL语句, ))
调试输出 (记录集1.到首记录 ())
组合框1.清空 ()
.计次循环首 (记录集1.记录数量, )
    记录集1.读文本 (“姓名”, 姓名)
    组合框1.加入项目 (姓名, )
    记录集1.到下一条 ()
 
.计次循环尾 ()
记录集1.关闭 ()
 
数据库连接1.关闭 ()
.版本 2
.支持库 eDB
 
.局部变量 性别, 文本型
.局部变量 年龄, 文本型
.局部变量 手机, 文本型
 
数据库连接1.连接Access (取运行目录 () + “\db1.mdb”, “”)
记录集1.置连接 (数据库连接1)
记录集1.打开 (“select  * from 表1, #SQL语句, )
记录集1.到首记录 ()
 
.计次循环首 (记录集1.记录数量, )
    记录集1.读文本 (“姓名”, 姓名)
    .如果 (姓名 = 组合框1.取项目文本 (组合框1.现行选中项))
        记录集1.读文本 (“性别”, 性别)
        记录集1.读文本 (“年龄”, 年龄)
        记录集1.读文本 (“手机”, 手机)
 
        编辑框1.内容 = 性别
        编辑框2.内容 = 年龄
        编辑框3.内容 = 手机
        返回 ()
    .否则
 
    .如果结束
 
    记录集1.到下一条 ()
 
.计次循环尾 ()
记录集1.关闭 ()
数据库连接1.关闭 ()

教程下载:

1-40
百度网盘链接:https://pan.baidu.com/s/1qbtE2cgi9sU1vganeIuv7w
41-88
百度网盘链接:https://pan.baidu.com/s/1Yf0neUBcUtet_eNN0SzNnQ

提取码:加QQ群:521068947 群文件下载

511遇见全部视频教程百度网盘下载

资源教程交流①群:521068947

511遇见QQ: 272586593


发布日期:

所属分类: 易语言 标签: