易语言APC应用层注入dll到游戏

注入流程

1、获取进程ID
2、注入DLL路径
3、注入DLL函数名称
4、执行APC注入
5、加载DLL
6、这里我们可以使用启动线程的方法反复调用注入函数

apc注入DLL 源码

.版本 2
.支持库 EThread
 
.程序集 程序集1
 
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
 
启动线程 (&thdll, , )
 
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
 
.子程序 thdll, , 公开
 
信息框 (“我是APC注入进去的DLL”, 0, , )

启动线程调用注入函数源码:

.版本 2
.支持库 spec
.支持库 EThread
 
.局部变量 函数地址
.局部变量 内存地址
.局部变量 线程ID
.局部变量 线程句柄
 
函数地址 = GetProcAddress (dll句柄, 编辑框3.内容)
内存地址 = 申请内存 (取文本长度 (编辑框3.内容), )
写到内存 (编辑框3.内容, 内存地址, )
线程句柄 = CreateThread (0, 0, 函数地址, 内存地址, 0, 线程ID)
.如果真 (等待线程 (线程句柄, 100))
    关闭线程句柄 (线程句柄)
    释放内存 (内存地址)
.如果真结束

教程获取下载:


发布日期:

所属分类: 易语言 标签: