易语言大漠剑侠情缘绑定游戏

部分源码:

.版本 2
 
.子程序 判断游戏开启
.局部变量 i, 整数型
 
' 1、寻找游戏窗口的句柄
i = 0
.判断循环首 (i = 0)
 
    进程_取ID数组 (“gamefree.exe”, ID数组, )
    .如果 (取数组成员数 (ID数组) > 0)
        hwnd = 进程_ID取窗口句柄 (ID数组 [1], , , )
        .如果真 (hwnd > 0)
            标签_信息.标题 = “游戏开启成功”
            时钟1.时钟周期 = 0
            i = 1
 
 
        .如果真结束
 
    .否则
        标签_信息.标题 = “请开启游戏”
    .如果结束
    处理事件 ()
 
.判断循环尾 ()
 
' 
' hwnd = dm.FindWindow (, “剑侠情缘·网络版”)
.' 如果 (hwnd > 0)
    ' 标签_信息.标题 = “游戏开启成功”
    ' 时钟1.时钟周期 = 0
    ' i = 1
 
.否则
    ' 标签_信息.标题 = “请开启游戏”
    ' 处理事件 ()
.如果结束
 
' 判断循环尾 ()


发布日期:

所属分类: 易语言 标签: