第12课易语言大漠一键登录账号密码写入文本

课程源码

.版本 2
.支持库 dp1
 
.子程序 保存账号
.局部变量 name, 文本型
.局部变量 pass, 文本型
.局部变量 passd, 字节集
.局部变量 文本内容, 文本型
 
name = _启动窗口.编辑框_账号.内容
pass = _启动窗口.编辑框_密码.内容
passd = 加密数据 (到字节集 (pass), “jxqy”, )
 
.如果 (假 = 文件是否存在 (取运行目录 () + “\zhm.txt”))
    写到文件 (取运行目录 () + “\zhm.txt”, 到字节集 (“”))
 
.否则
 
.如果结束
 
文本内容 = 到文本 (读入文件 (取运行目录 () + “\zhm.txt”))
' 只有账号和密码不为空时,才执行下面的步骤
.如果 (name = “” 或 pass = “”)
    返回 ()
.否则
    ' 判断一下name是否重复,有的话返回不再写入,没有的话写入文本
.如果结束
.判断开始 (寻找文本 (文本内容, name, ,) = -1)
    文本内容 = 文本内容 + name + “|” + 到文本 (passd) + #换行符
    写到文件 (取运行目录 () + “\zhm.txt”, 到字节集 (文本内容))
 
.默认
 
.判断结束


发布日期:

所属分类: 易语言 标签: